how to get rid of "System policy prevents modification of network settings for all users"?

how to permanently get rid of “System policy prevents modification of network settings for all users”?

using gnome on every startup/reboot I get this message where I have to type my root password to continue which is very annoying. I did store the password in the kde wallet (kde is also installed but I mostly use gnome).

I found a working solution in this forum but the thread was closed so I had to start this new thread:

this working solution only works during the current session. Once I reboot my openSUSE I have to run:

sudo /sbin/set_polkit_default_privs

so is there a way to make this solution permanent?
or a workaround to run the line of code at every startup?
I also have some other lines of root code I would like to run on every startup,
I would like to make some startup script with al these lines of code without typing my root pwd on every boot.

In the Network Manager profile for that connection, select the ‘Allow all users to use’ checkbox, enter root password once and should be good to go.

hi thanks for your response.

I checked but the: ‘Allow all users to use’ checkbox was already “on” (checked)…

any other things I can do?

Is it checked if you reboot and don’t run the policy kit command?

I would delete the connection and create a new one if above still has issues.

That was your mistake.

Simplest solution would be to delete the connection, and then set it up using Gnome. The defaults for Gnome will do what you want.

Indeed! This solved my problem. Thank you.
So is there a gnome equivalent of the “kde.wallet” I better use in the future?

There is a Gnome keyring. However, when you setup a NetworkManager connection in Gnome, it stores the password in an ordinary file (only readable by root). And that avoids the problem completely. The KDE default is to store the password in kde-wallet, although you can change it to store in a file.