How To Get QT zypper GUI in GNOME YAST

Alrighty, this will be a really short howto, but I would never have known I could do this if it hadn’t been mentioned offhand here, and so I figure others might benefit as well.

The discussion at the link above boils down to an opinion that the YAST “Software Management” button under KDE brings up a more usable and functional interface than in GNOME. I now share that opinion, and thanks to this switch I no longer pine for synaptic.

It’s super easy.

  • As root do “zypper in yast2-qt-pkg” from a terminal session, OR use “Software Management” from within YAST to search for and install it.

  • From within YAST, click “/etc/sysconfig Editor” in the “System” section.

  • Expand System–>Yast2–>GUI–>WANTED_GUI

  • Change the setting of WANTED_GUI from auto to qt.

  • Click “Finish”, acknowledge any prompts, and you are done.

I forgot to mention this was done in openSUSE 11.0

Just to add to this. Because this is a very handy feature if you use Gnome. In Software Management- The feature QT offers which is of great advantage it: ‘Update All in this List’ and you can choose then either ‘If newer version available’ or ‘Unconditionally’.

I have put a couple of screens to help you see the settings to change.
First make sure the yast2-qt-pkg is installed.

http://thumbnails18.imagebam.com/3255/4d6f4832545417.gif](http://www.imagebam.com/image/4d6f4832545417/) http://thumbnails17.imagebam.com/3255/9e1f3c32545425.gif](http://www.imagebam.com/image/9e1f3c32545425/)

Hope this helps.

been a little while since I used the QT zypper front end. But if I remember correctly, the QT version is a lot better then the gtk one.

just want to add:
on 11.2, you also need to change WANTED_SHELL to qt to have the desired result

This does not work in KDE 11.3 or 11.4

HOLY RESURRECTED THREAD, BATMAN!

In 11.4 and from the command line, ‘su -’ to root and execute the following:

yast2 --qt

Did that and after close it reverts to the ugly X or curses interface.

Launchin yast from command line seems to assure it goes to qt, but from the menu it always does the ugly interface. I looked in the menu entry, and its not clear to me why that may be.

/usr/bin/xdg-su -c /sbin/yast2

Not sure the “correct” way to do it then, but you could change the menu entry to say:

/usr/bin/xdg-su -c “/sbin/yast2 --qt”

This will force it to use qt every time.

Well I tried that, and it refuses to launch that way. What an odd bug.

I tried that, and it failed to launch. What an odd bug.

On Sat, 2011-04-02 at 03:06 +0000, Shadowolf7 wrote:
> Launchin yast from command line seems to assure it goes to qt, but from
> the menu it always does the ugly interface. I looked in the menu entry,
> and its not clear to me why that may be.
>
> /usr/bin/xdg-su -c /sbin/yast2
>
>
Hi
Sure you have yast2-qt installed?


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.29-0.3-default
up 2 days 2:25, 3 users, load average: 0.57, 0.31, 0.20
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.26

Yes, I made certain of that. And it works if I launch YAST from command line. Such an odd bug.

Switch Yast Interface to QT

I did that! That was the first thing I tried, and it doesn’t work. YAST is perfectly functional, its more a cosmetic concern… but I like things to be pretty and consistent.

I don’t understand. Cosmetic. You mean you don’t like the look of it?

Did you get those files by the way?

The Qt is more cosmetic, I was reading more, and it looks like maybe is is using Qt, but is defaulting on a theme that the desktop doesn’t use. Odder still.

Yes.

This QT UI in Gnome for me

http://dl.dropbox.com/u/10573557/SUSE%20Misc/qt_in_gnome.png

1.1

/usr/bin/xdg-su -c "/sbin/yast2 --qt"

entered in a normal user’s terminal emulator works for me
(starting the graphical YaST Control Center and then the Software Manager like it would be in KDE/LXDE/Xfce although I was in GNOME).

1.2

su -

/usr/bin/xdg-su -c "/sbin/yast2 --qt"

works not for me.

1.3

su -

/sbin/yast2 --qt

works for me (see 1.1).

Maybe the problem is related with becoming root/getting root privileges
the second time and/or
the xdg-utils?
Compare (for my - maybe odd/a bit broken 11.4 system - ):

By the way:
To the term “QT zypper GUI” - I thought yast2 and the YaST module Software Manager would not be depending on zypper - just that the YaST module(s) for software management and zypper were both depending on libzypp.
Compare:
Portal:Libzypp - openSUSE
ZYpp - Wikipedia, the free encyclopedia

Regards
Martin
(pistazienfresser)