How to fix update issue

Whenever I use zypper dup i always get an error that
“apache2-mod_php7-7.4.33-2.1.x86_64 could not be erased”
If I go to Software Management and try to remove it i get the same error. I am also unable to force update it with Software Management. Ignoring the error and continuing the update also hasn’t fixed it and the next “zypper dup” will have the same problem as zypper rm or Software Management:

# zypper rm apache2-mod_php7-7.4.33-2.1.x86_64
Reading installed packages...
Resolving package dependencies...

The following package is going to be REMOVED:

1 package to remove.
After the operation, 4.4 MiB will be freed.
Continue? [y/n/v/...? shows all options] (y): y
error: %preun(apache2-mod_php7-7.4.33-2.1.x86_64) scriptlet failed, exit status 1
error: apache2-mod_php7-7.4.33-2.1.x86_64: erase failed
(1/1) Removing apache2-mod_php7-7.4.33-2.1.x86_64 ............................[error]
Removal of (76)apache2-mod_php7-7.4.33-2.1.x86_64(@System) failed:
Error: Subprocess failed. Error: RPM failed: Command exited with status 1.
Abort, retry, ignore? [a/r/i] (a):

There is already a thread about this topic.

rpm -e --noscripts apache2-mod_php7-7.4.33-2.1.x86_64 worked.