How to enable GPU (AMD Radeon HD 8500 M) on my Lenovo laptop?


I’m newbie, with laptop Lenovo, i7 CPU+GPU, and AMD Radeon HD 8500 M GPU
Installed opensuse 13.2. Didn’t download driver from AMD site, but followed tutorial adding driver with ‘one click’

In Yast I am seeing now installed, added repos also, MESA also, but still didn’t working the GPU.

I’ve tried solve the problem with following way, but didn’t success:

attila@linux-qizk:~> fglrxinfo
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Error: couldn’t find RGB GLX visual!

attila@linux-qizk:~> aticonfig --lsa

    1. 03:00.0 AMD Radeon HD 8500M
    • Default adapter

Could anybody help me with this mobility radeon, or link step by step tutorial?? Thank you

Actually just installing the driver should be enough.

Can you please post the file /var/log/Xorg.0.log? (upload to or similar and post a link)

Are you maybe booting to “recovery mode”?

I am booting normal…

Well, your system is using the intel driver (whose GLX is broken when proprietary drivers like fglrx or nvidia are installed), and there’s no mention of an AMD/ATI card at all.

Are you sure it’s not disabled in the BIOS settings or similar? (some hybrid systems allow this)

Can you please post the output of “/sbin/lspci”?

I used previous Win 10, then I reformatted everything, so its non dual boot. On Win 10 everything worked fine. Output of lspci:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
02:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
03:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun LE [Radeon HD 8550M / R5 M230]

So it is there.
But Xorg doesn’t seem to see it…

Unfortunately I don’t have any experience with those hybrid systems. I just know that normally Xorg should load the fglrx driver, which then does the switching between intel and AMD as desired.

You could try running “sudo aticonfig --initial” to create an xorg.conf that explicitely loads fglrx.
But that might also just prevent Xorg (the graphical interface) from starting…
If that happens, boot to “recovery mode” (2nd option in “Advanced Options” in the boot menu), and remove the file /etc/X11/xorg.conf (not the directory /etc/X11/xorg.conf.d ! ) again.
And please provide /var/log/Xorg.0.log.old before you reboot from recovery mode, maybe it might contain something that is of interest.

Tried aticonfig, it “switched to AMD”. Then restarted, but before login jump out from KDE. Then I restarted, deleted xorg.conf, now I restored the old situation :frowning:

Ok, I suspected that.
But what about the log file?

Again, please do this:

  • Run “aticonfig --initial”
  • Reboot, until the system drops back to text mode
  • Reboot and select “recovery mode” (2nd entry in “Advanced Options” in the boot menu)
  • Post the file /var/log/Xorg.0.log.old
    If you can’t work satisfactorily in “recovery mode” (or KDE doesn’t start there either), copy the file to some other place and post it after you restored the “old situation”.
cp /var/log/Xorg.0.log.old ~/Desktop

The log file contains the log from the previous boot, i.e. the one that failed.

It does see it:

  82808.887] (--) PCI: (0:3:0:0) 1002:666f:17aa:380c rev 0, Mem @  0xb0000000/268435456, 0xd0400000/262144, I/O @ 0x00003000/256, BIOS @  0x????????/131072

Yes, it is worth to try to create xorg.conf file with aticonfig --initial.

The Xorg.0.log.old is in recovery mode:

The xorg.conf is:

Try to remove the line:

        BusID       "PCI:3:0:0"

According to this might help.

So…deleted xorg.conf, then again:
aticonfig --initial
removed line BusID “PCI:3:0:0” from new xorg.conf
still same problem… jump out from KDE before login to X. I didnt noticed any ugly AMD logo …

The first problem, seems, is here:

    30.545] (II) "glx" will be loaded by default.
    30.545] (II) LoadModule: "glx"
    30.636] (WW) Warning, couldn't open module glx
    30.636] (II) UnloadModule: "glx"
    30.636] (II) Unloading glx
    30.636] (EE) Failed to load module "glx" (module does not exist, 0)

Could you show the content of /usr/lib64/xorg/modules/extensions/? There should be a symlink pointing on fglrx/ If is absent here, does it exist anywhere in your machine?

Yes, the content of extensions folder are: 2 folders (fglrx, xorg) and 1 file is not in 64bit folder, but here: /usr/lib/xorg/modules/extensions

The fglrx64 and fglr packages installed

Now I have another problem when I try initial aticonfig:

attila@linux-qizk:~> sudo aticonfig --initial
root’s password:
aticonfig: error while loading shared libraries: cannot open shared object file: No such file or directory

I think, the simplest way is to reinstall driver. There are some strange paths in the current installation… Uninstall it;

# lspci -nnk -s 00:03:00.0

has show just radeon driver. Then once more try to install it from repository. If nothing changes, try a driver from

  • unisntalled fglrx

  • tried reinstall from for HD 8xxx, unfortunately catalyst install stopped, install files not support my gpu

  • reinstall one click from opensuse

  • aticonfig --initial

  • checked, now is linked in extensions 64 bit :smiley:

  • reboot, jumps back again :frowning:

  • reboot, recovery, removed line from xorg.conf (BusID “PCI:3:0:0” )

  • reboot, jumps back again :frowning:

I wont give up :smiley:


# aticonfig --initial -f

reboot (obtaining black screen), and show the corresponding Xorg.0.log, please.

The line with BusID should be present in the xorg.conf.

Seems we have the same problem (Intel / ATI PowerXpress & fglrx)… Look also in dmesg: if there are lines like

   33.171943] <6>[fglrx] Try to set gart size 2697M failed, should be within 0M and 0M. Discard the setting.
   33.470587] fglrx_pci 0000:01:00.0: irq 47 for MSI/MSI-X
   33.470956] <3>[fglrx:mc_heap_add_reserved_range] *ERROR* Can not allocate dummy heap
   33.470958] <3>[fglrx:MCIL_AllocateMemory] *ERROR* Can not allocate requested gart cacheable memory for IVRING
   33.471029] <6>[fglrx] IRQ 47 Enabled
   33.479841] <6>[fglrx] Reserved FB block: Shared offset:0, size:1000000 
   33.479843] <6>[fglrx] Reserved FB block: Unshared offset:7738000, size:4000 
   33.479844] <6>[fglrx] Reserved FB block: Unshared offset:773c000, size:5c4000 
   33.479845] <6>[fglrx] Reserved FB block: Unshared offset:7ffee000, size:12000 
   33.483633] <3>[fglrx:firegl_cmmqs_init] *ERROR* CMMQS initialization is failed.
   33.483637] <3>[fglrx:hal_init_gpu] *ERROR* CMMQS Initialization failed: hal_init_gpu
   33.483639] <6>[fglrx] device open failed with code -1

join abovementioned topic at AMD forum and corresponding bug report Bug 1019 .

OMG, As I see now this will neverending story. I will switch back to Win10, I have really no time playing with this - I am just common user, not geek. Thanks for support anyway.