how to disable system beep warning sound?


I found that each time when I try to close certain program, suse always give us some noisy beep sound for warning… I am just wondering how can we disable it? I remember that it could decrease the volume from Configure Desktop in openSUSE 13.x, but I cannot find in the Leap.

thx a lot:P

Just to clarify that you’re referring to the KDE desktop?

A volume slider for notifications should show up in the “Volume Control Settings” (right-click on the volume control icon in the system tray) while a notification is played.

As this might be difficult to catch (notifications are very short normally…) better run kmix (you might have to install it first), this has an explicit volume slider for event notifications. If you prefer to use kmix as volume control in general, you can disable Plasma’s new “Volume Control” applet in the “System Tray Settings”, or uninstall plasma5-pa. In that case you should probably also enable “Autostart” in kmix’s settings though, it is disabled by default in Leap.

Or disable the notifications you don’t want in “Configure Desktop”->Notifications. The one you refer to is probably “KDE Plasma Workspace”->“Warning message” (or similar).

Thanks for suggestions.

The volume slider doesn’t work. Even I mute everything, when I try to close a program, the warning beep sound is still there.

I disabled all sound from “KDE Plasma Workspace”->“Warning message” (or similar), and it till doesn’t work…

I noticed that in opensuse 13.2, it can be set by disable: system settings–> application and system notification–> system Bell

However, I didn’t find this option in Leap…

Forget about my previous thread.

I found it in Leap by “search”. It is in :

Desktop behaviour–> accessibility–>Bell