how to disable nouveau driver?

Hello there.

I’m trying to disable the nouveau driver by blacklisting it in /etc/modprobe.d, but it’s still loading after reboot. And it worked few months ago.
Any thoughts?


If you put “nomodeset” on the grub command line (last parameter to the “linux” or “linuxefi” line, then nouveau should not load. You can make that change permanent by eding “/etc/default/grub”.

what are you using instead of nouveau?
are you using the propitiatory drivers, how are you installing them, the nvidia rpm’s automatically disable nouveau there is no need to blacklist it, there was a recent kernel update did you update the nvidia driver?

that’s what i’m trying to do. Since nvidia repo can not catch up with kernel updates, i’m installing it manually (and if i install one from repo, X Windows crashed on boot). And nvidia install file is disabling the nouveau drivers the same way, by blacklisting it, and it does not work. After reboot the nouveau driver is still loading, so i can not install nvidia drivers

thanks a lot, mate!

That helped. I was able to reboot with no nouveau and then successfully installed nvidia driver
Do you know why blacklisting the nouveau driver was not working?

I think there’s an issue with nvidia’s hosting
it was present a few months ago too, nvidia uses some sort of cloud storage we don’t use the same IP for their ftp and the issue is with their cloud provider my nvidia driver updated the same time as the kernel did.
using nomodset is good for fixing things but disabling userspace for general use is a bad idea do not do it, if you are having issues with the nvidia ftp use their run file and manually update the driver when there is a kernel update a user wrote a batch script that automatically updates the nvidia driver, leave novou be it will be used if the propitiatory driver gets broken it’s much better then the alternative nv driver.

Its a driver stack, not a single driver. The major components include:

  • the nouveau kernel driver … (which does kms – kernel modesetting)
  • the nouveau X driver
  • the Mesa nouveau component

Blacklisting only prevents loading of the kernel module at boot. If you subsequently start up an X session, and X decides its going to load the nouveau X driver, the kernel driver is also loaded (as the X driver requires it for modesetting)

If you use the nomodeset option at boot, no kms drivers can be used (period). If you subsequently start up an X session, and X decides its going to try to load the nouveau X driver, it will fail (as the necessary nouveau kms kernel driver has been banished) and so X will fallback to a basic driver like nv or fbdev …

You also must run mkinitrd for the blacklisting to work.