how to disable interface in Networkmanager

Hi,
How can I disable rteth0,rtlo network interfaces to appear in network manager ??

The next file has no effect

/etc/NetworkManager/NetworkManager.conf

[main]
plugins=ifcfg-suse,keyfile


[keyfile]
unmanaged-devices=interface-name:rtlo;interface-name:rteth0;

You can specify unmanaged devices by their mac address. Edit /etc/NetworkManager/NetworkManager.conf and create a ‘[keyfile]’ section. Add the devices like this

[keyfile]
unmanaged-devices=mac:00:22:68:1c:59:b1;mac:00:1E:65:30:D1:C4

Refer ‘man NetworkManager.conf’ for more info.

Did you restart NetworkManager after making the edit?

Need clarity,
Do you just want those network interfaces to not appear in Network Manager but still function?
The above describes how to achieve this result.

But,
If you’re trying to disable the network interfaces so that they don’t function,
Then you’ll have to disable at a lower level, one place is the interface file itself (or, I expect you can do this in YaST).

TSU