How to disable CTRL+ALT+Plus/Minus zoom in Plasma 5?

I noticed pressing CTRL+ALT+Plus/Minus zooms in/out the content of my desktop graphics and pretty much messes up everything on screen. This shortcut key is conflicting an application which uses it (that’s how I actually found it), so I am unable to use the shortcut in the application.

Unfortunately I couldn’t find any option to disable this global shortcut in System Settings. I don’t find any such shortcut in global shortcuts.

Any idea how to get rid of that?

Maybe System Settings->Workspace Behavior->Desktop Effects.

Disable the “Zoom” effect completely, or change the shortcut in its settings.
Though the default shortcuts for zooming in/out are Meta(i.e. the Windows key)+Equal/Minus, on my system at least…

I tried that already but nothing changed. For me it is also Meta+Equal/Minus but this one works fine - it zooms in and out smoothly and in steps and does not corrupt the whole picture like the other thing.

So I was wondering if it is perhaps not a feature of Plasma but of X11… but I have not enough knowledge about that, so I decided to ask.

Ctrl+Alt+Plus/Minus doesn’t do anything on my system.

What do these commands say?

grep Ctrl ~/.config/khotkeysrc
grep Ctrl ~/.config/kglobalshortcutsrc

This should list all global KDE shortcuts that contain Ctrl.

IIRC Ctrl+Alt+(Keypad)Plus/Minus were indeed global X11 shortcuts in previous openSUSE versions, but that must have been changed/disabled years ago.
“man xorg.conf” say this though:

       **Option "DontZoom"**  "boolean"
              This  disallows  the  use  of   the   **Ctrl+Alt+Keypad-Plus**   and
              **Ctrl+Alt+Keypad-Minus**  sequences.  These sequences allows you to
              switch between video modes.  When this option is enabled,  those
              key sequences have no special meaning and are passed to clients.
              Default: off.

So maybe also post the output of:

grep -R Zoom /etc/X11/xorg.conf*

**grep Ctrl ~/.config/khotkeysrc**





Comment=After pressing Ctrl+Alt+I, the KSIRC window will be activated, if it exists. Simple.
Comment=After pressing Alt+Ctrl+H the input of 'Hello' will be simulated, as if you typed it.  This is especially useful if you have call to frequently type a word (for instance, 'unsigned').  Every keypress in the input is separated by a colon ':'. Note that the keypresses literally mean keypresses, so you have to write what you would press on the keyboard. In the table below, the left column shows the input and the right column shows what to type.

"enter" (i.e. new line)                Enter or Return
a (i.e. small a)                          A
A (i.e. capital a)                       Shift+A
: (colon)                                  Shift+;
' '  (space)                              Space
Comment=This action runs Konsole, after pressing Ctrl+Alt+T.
Comment=Read the comment on the "Type 'Hello'" action first.

Qt Designer uses Ctrl+F4 for closing windows.  In KDE, however, Ctrl+F4 is the shortcut for going to virtual desktop 4, so this shortcut does not work in Qt Designer.  Further, Qt Designer does not use KDE's standard Ctrl+W for closing the window.

This problem can be solved by remapping Ctrl+W to Ctrl+F4 when the active window is Qt Designer. When Qt Designer is active, every time Ctrl+W is pressed, Ctrl+F4 will be sent to Qt Designer instead. In other applications, the effect of Ctrl+W is unchanged.

We now need to specify three things: A new shortcut trigger on 'Ctrl+W', a new keyboard input action sending Ctrl+F4, and a new condition that the active window is Qt Designer.
Qt Designer seems to always have title 'Qt Designer by Trolltech', so the condition will check for the active window having that title.
Name=Remap Ctrl+W to Ctrl+F4 in Qt Designer
Comment=By pressing Alt+Ctrl+W a D-Bus call will be performed that will show the minicli. You can use any kind of D-Bus call, just like using the command line 'qdbus' tool.
Comment=Read the comment on the "Type 'Hello'" action first.

Just like the "Type 'Hello'" action, this one simulates keyboard input, specifically, after pressing Ctrl+Alt+B, it sends B to XMMS (B in XMMS jumps to the next song). The 'Send to specific window' checkbox is checked and a window with its class containing 'XMMS_Player' is specified; this will make the input always be sent to this window. This way, you can control XMMS even if, for instance, it is on a different virtual desktop.

(Run 'xprop' and click on the XMMS window and search for WM_CLASS to see 'XMMS_Player').

**grep Ctrl ~/.config/kglobalshortcutsrc**
Switch to Next Keyboard Layout=Meta+Alt+Space,Ctrl+Alt+K,Switch to Next Keyboard Layout
next=Ctrl+Alt+PgDown,Media Next,Next Track
play_pause=Ctrl+Alt+Home,Media Play,Play/Pause
prev=Ctrl+Alt+PgUp,Media Previous,Previous Track
replay=Ctrl+Alt+Ins,none,Restart current track
seek_backward_medium=Ctrl+Alt+Left,Meta+Shift+-,Seek Backward by 10 seconds
seek_forward_medium=Ctrl+Alt+Right,Meta+Shift++,Seek Forward by 10 seconds
stop=Ctrl+Alt+End,Media Stop,Stop
toggleMainWindow=Ctrl+~,none,Toggle Main Window
Show System Activity=Ctrl+Esc,Ctrl+Esc,Show System Activity
{5c94cfad-4779-4d93-850d-99a1fe16e8b6}=Meta+Ctrl+Alt+Shift+Ins,none,Reset Volume
clipboard_action=,Ctrl+Alt+X,Enable Clipboard Actions
cycleNextAction=Ctrl+Shift+PgDown,none,Next History Item
cyclePrevAction=Ctrl+Shift+PgUp,none,Previous History Item
repeat_action=,Ctrl+Alt+R,Manually Invoke Action on Current Clipboard
decrease_volume=Ctrl+Alt+Down,Volume Down,Decrease Volume
increase_volume=Ctrl+Alt+Up,Volume Up,Increase Volume
ReadMessage=Ctrl+Shift+I,Ctrl+Shift+I,Read Message
Set_Away_Back=Ctrl+Shift+W,Ctrl+Shift+W,Set Away/Back
ShowContactList=Ctrl+Alt+T,Ctrl+Alt+T,Show/Hide Contact List
Halt Without Confirmation=Ctrl+Alt+Shift+PgDown,none,Halt Without Confirmation
Lock Session=none,Ctrl+Alt+L	Screensaver,Lock Session
Log Out=Ctrl+Alt+Del,none,Log Out
Log Out Without Confirmation=Ctrl+Alt+Shift+Del,none,Log Out Without Confirmation
Reboot Without Confirmation=Ctrl+Alt+Shift+PgUp,none,Reboot Without Confirmation
Activate Window Demanding Attention=Ctrl+Alt+A,Ctrl+Alt+A,Activate Window Demanding Attention
Expose=Ctrl+F9,Ctrl+F9,Toggle Present Windows (Current desktop)
ExposeAll=Ctrl+F10,Ctrl+F10	Launch (C),Toggle Present Windows (All desktops)
ExposeClass=Ctrl+F7,Ctrl+F7,Toggle Present Windows (Window class)
Kill Window=Ctrl+Alt+Esc,Ctrl+Alt+Esc,Kill Window
ShowDesktopGrid=Ctrl+F8,Ctrl+F8,Show Desktop Grid
Switch to Desktop 1=Ctrl+F1,Ctrl+F1,Switch to Desktop 1
Switch to Desktop 2=Ctrl+F2,Ctrl+F2,Switch to Desktop 2
Switch to Desktop 3=Ctrl+F3,Ctrl+F3,Switch to Desktop 3
Switch to Desktop 4=Ctrl+F4,Ctrl+F4,Switch to Desktop 4
clipboard_action=Ctrl+Alt+X,Ctrl+Alt+X,Enable Clipboard Actions
cycleNextAction=Meta+Ctrl+Alt+Shift+PgDown,none,Next History Item
repeat_action=Ctrl+Alt+R,Ctrl+Alt+R,Manually Invoke Action on Current Clipboard
show dashboard=Ctrl+F12,Ctrl+F12,Show Desktop
Map to fullscreen=Meta+Ctrl+F,Meta+Ctrl+F,Map to fullscreen
Map to screen 1=Meta+Ctrl+1,Meta+Ctrl+1,Map to screen 1
Map to screen 2=Meta+Ctrl+2,Meta+Ctrl+2,Map to screen 2
Next Profile=Meta+Ctrl+N,Meta+Ctrl+N,Next profile
Previous Profile=Meta+Ctrl+P,Meta+Ctrl+P,Previous Profile
Toggle screen map selection=Meta+Ctrl+M,Meta+Ctrl+M,Toggle between all screens
Toggle stylus mode=Meta+Ctrl+S,Meta+Ctrl+S,Toggle the Stylus Tool Relative/Absolute
Toggle touch tool=Meta+Ctrl+T,Meta+Ctrl+T,Enable/Disable the Touch Tool

grep -R Zoom /etc/X11/xorg.conf* shows nothing

BTW it seems to be related to the video driver (or X11) as it flickers and leaves some artifacting on the screen. The only way to remove them is to logout.

Still, try to set DontZoom explicitly, the manpage says it is off (i.e. Zoom is on) by default.
Create a file /etc/X11/xorg.conf.d/20-serverflags.conf (the exact name doesn’t matter, it only has to end with .conf) with the following content:

Section "ServerFlags"
Option "DontZoom" "on"

That worked!

Thank you so much :slight_smile:


As those shortcuts switch between the available resolutions, it might indeed depend on the graphics driver (and/or the monitor) whether they do anything by default or not.
And the graphics corruption you mention may be a bug in the driver, or in Plasma when it detects the resolution change.
But IIRC you disabled KScreen2, right? So Plasma should not notice the change at all. Exactly this might cause the problems in the first place, I’m not sure though.

Btw, there are other global X11 shortcuts that you can disable in this file if you want to.
E.g. Ctrl+Alt+Backspace (twice) killing the X server:

Option "DontZap" "on"

Or switching to different VTs via Ctrl+Alt+Fn:

Option "DontVTSwitch" "on"

See “man xorg.conf” for more details…

Yes I disabled KScreen2 (you have amazing memory!)
Thanks for the additional options. I find it useful to be able to kill X11 (in case of need) or to switch to VTs. But good info anyway :slight_smile: