How to disable CPUFreq ?

I’m using suse 11.1 x86_64 on AMD XP 3000+. During boot I get a message:

Loading CPUFreq modules (CPUFreq not supported)

How to disable loading of CPUFreq modules? Since it’s not supported I don’t want to waste time on it. I added CPUFREQ=no to grub and this works - the message is gone - however to me it seems that it’s only a workaround, not a real solution. Probably blacklisting this module would be a better solution, but I don’t know the name of the module (tried acpi-cpufreq, but the message still appeared).

I would stick with the first method (=solution) as that gets acted on first at boot.

For me it’s not a real solution - grub options are not the right place to blacklist modules. Besides, it gets erased after a kernel upgrade, since grub entries are restored to default (I just experienced this).