how to decrease screen brightness

my screen brightness increased and it’s dangerous for my eyes!!

maybe it’s help you

/sys/class/backlight/acpi_video0> ls
actual_brightness  brightness  max_brightness  subsystem  uevent
bl_power           device      power           type
shahab@linux-8gy9:/sys/class/backlight/acpi_video0> head brightness
shahab@linux-8gy9:/sys/class/backlight/acpi_video0> head max_brightness
shahab@linux-8gy9:/sys/class/backlight/acpi_video0> head actual_brightness

brightness is 0 .why screen brightness is full now?!
the Fn key is not work for increase & decrease

What type of laptop is it, what version of openSUSE are you running, and what type of graphics card do you have?

I have a similar problem. On a intel/nvidia (optimus) setup (asus n56 with the entire asus-wmi keyboard thing). With bumblebee/nvidia driver installed from overman’s repo.

When using only the default intel driver, brightness controls work as you would expect. They set a device in sys/class/backlight/, and so on, no problem. OSD turns up.

After installing the proprietary display driver (and disabling it with bbswitch and so on), apparently the increase and decrease script is associated with some other, presumably non-existent device in sys/class/backlight , so none of those devices are changed with the brightness tilt, and the OSD doesn’t show up. Or, I guess, the key event isn’t associated with the right class, or an nvidia type of event is expected, perhaps.

Not really sure what actually happens, but in my case I can still set the brightness controls in intel_backlight. And this changes the actual brightness. Passing a different… acpi_backlight=vendor or something like that in the boot changes the devices in sys/class/ (get an asus-nb-wmi device instead of other “video0” devices), but won’t change anything else, or catch the key-events.

(Honestly curious about what is actually going on here. But… not completely convinced this is a “bumblebee” problem, or specifically an nvidia proprietary driver problem.)

Different laptop brands have different ways of adjusting screen brightness. But If you understand the concept it will be easier for you. So follow these guideline.
[FONT=times new roman]Many laptops adjust their brightness and other settings using the function key in conjunction with another key. For example, pressing and holding function key (“Fn”) and pressing the up or down arrow keys can increases and decreases the brightness.
Also see more support materials here Acer Aspire 5732Z: Issue with screen brightness | Techyv.


He is using an Acer 5755g and openSUSE 12.3 KDE.

There is also a new KDE daemon that is in Configure Desktop–>System Settings–>Shortcuts and Gestures–>Global Keyboard Shortcuts.
Next to KDE component, click on the drop-down arrow and select KDE daemon.
Click on Decrease Screen Brightness, choose Custom
Click once on the None button and assign the keyboard combo that the Acer 5755g can use to decrease the light level.

Repeat the same steps with Increase Screen Brightness and click on the Apply button.

You may have to restart your laptop to see the results.

Try this:
echo 65 | sudo tee /sys/class/backlight/intel_backlight/brightness


echo 65 | sudo tee /sys/class/backlight/acpi_video0/brightness

thank you very very much:kiss:
and special thank to all of you:)
i changed 65 to 5 and my scren turned off :))) but i’m lucky because your command saved to terminal and i use it by up key…

how i can save this?it’s back to increase mode after reboot

I have already explained it earlier. Please read my Comment 5 about setting up your keys for decreasing and increasing brightness. All settings get written to a file which can be used for export to file.

Make a print out of it. Yes.

Weird. So on my asus, I have this asus-wmi device registered with xinput. And this has events for a lot of different keys (keyboard light, volume, etc. But the brightness up/down keys (fn+f4/f5) don’t register at all. Either with xinput->keyboard or the wmi-device.

Another strange thing - there’s a hardware button on my n56 that actually generates a key-event on the wmi-device. But this key (unlike the volume, keyboard backlight, etc) generates an “unknown event” in the system log.

…I don’t know enough to figure out what’s going on here. But maybe the key-event is overriden by some other module? The event is stolen by the nvidia driver, something like that :stuck_out_tongue:

(I kind of solved it for me with a toggle-script like this, though…

  1. Gave /sys/class/backlight/intel_backlight/brightness write permission as user.
  2. Associated this script under here to a keyboard combination gnome recognizes (see keyboard->shortcuts).

Please don’t use it without modifying the paths and values first. I… just didn’t want to make it read in a bunch of values every time I hit the key. And thought it was too much work to make a few different functions for reading up/down, etc. Max, min and “current” values can be read from the directory with the backlight “device” you’re using, and so on. …anyone know in which universe “4882” is a reasonable “max” level, by the way? It’s not half of some ^2 number, so… ?)

#! /bin/sh
# Script to toggle brightness to either "low" or "high".
# To be called from dedicated hardware buttons, etc.


read CURRENT < /sys/class/backlight/intel_backlight/brightness

    echo $BRIGHTNESS_HALF > /sys/class/backlight/intel_backlight/brightness
    echo $BRIGHTNESS_MAX > /sys/class/backlight/intel_backlight/brightness

Interesting. KDE4 has added a new KDE daemon to handle brightness. See below:

  • To get started, navigate to the Start button–>Configure Desktop–>System Settings–>Shortcuts and Gestures–>Global Keyboard Shortcuts
    . - Next to KDE component
    , click on the drop-down arrow and select KDE daemon. - Click on Decrease Screen Brightness
    , choose Custom - Click once on the None
    button and assign the keyboard combo(s) that your laptop can use to decrease the light level. - Repeat the same steps with Increase Screen Brightness
    and click on the Apply button.

You may have to restart your laptop to see the results.

Romanator ,

it’s dosn’t working! it’s can’t change brightness

Mm. …so my holistic debugging skills :stuck_out_tongue: makes me think the problem we’re having is that the key-events that are supposed to be used for the brightness controls either aren’t mapped at all. Or that they’re hijacked by a module that loads after the virtual keyboard module that reads the scancode. So the keys won’t be associated with the event for controlling brightness (…while the function the keys are supposed to trigger actually works).

(Or maybe it’s that on top of that the function tries to write to a set of backlight devices that doesn’t control the brightness.)

So… anyone have a good idea about how you would go about figuring out how those keys “disappear”?

Go into your BIOS and check if it is set to use Intel only and then try again.

Did you assign the numbers below:

echo 65 and echo 5?

Which of the following commands worked?

echo 65 | sudo tee /sys/class/backlight/intel_backlight/brightness


echo 65 | sudo tee /sys/class/backlight/acpi_video0/brightness

echo 65 | sudo tee /sys/class/backlight/intel_backlight/brightness

it’s worked
assign that numbers, where?!

  1. Navigate to Configure Desktop–>System Settings–>Shortcuts and Gestures–>Custom Shortcuts
  2. Select Edit–>New–>Global Shortcut–>Command/URL
  3. Assign a name i.e. Increase brightness
  4. Select the Comment tab
    and type in Increase Brightness 1. Select the Trigger tab **
    and assign your keyboard shortcut 1. Select the
    Action tab**
    and copy the command from konsole to Command/URL section 1. Click on the Apply button
    to confirm the changes.

That’s it. You may have to restart your laptop. Please work on it.


I’m a newbie in openSUSE, but not in system administration on win. I have a several problems with my work notebook ACER E1-572 Acer | Aspire E | Aspire E1-572P-6403 | Datasheet without windows 8 and installed OpenSUSE 13.1 KDE.
One of them is based on this tread. Display brightness don’t changes with default hot keys (Fn+arrow< and Fn+arrow>). Nothing happens when trying this combo of buttons. With other hot keys all functions working fine and on display can see how it works.
When I tried these settings in **Configure Desktop–>Shortcuts and Gestures–>Global Keybord Shortcuts–>KDE Daemon **from default hot key to F9 and F10 after save utility started to work, but brightness don’t changes.
If I trying to change display brightness from **Configure Desktop–>Power Management–> Screen Brightness **the result is the same. Utility works, but no action on display.

Then I tried echo 65 | sudo tee /sys/class/backligh/intel_backlight/brightness command and the brightness changed.

It is possible to get working this function without **Terminal **​with hot keys???

I have a second Notebook HP Compax nx6310 and there are no problems with openSUSE 13.1 all functions works fine and PC works correctly without problems. Before I tried openSUSE I worked with ubuntu 12.04 and 13.10 and with these platforms I was a lot of problems with both of them.

Try to add this kernel parameter: acpi_backlight=vendor acpi_osi=Linux.
Add it to the end of the GRUB_CMDLINE_LINUX variable in the /etc/default/grub file.
Then run the* grub2-mkconfig -o /boot/grub2/grub.cfg* command …

Thanks a lot!

It works fine. Now works with default hot key too. When decrease or increase brightness utility don’t show percentage, but when I unplug AC adapter utility shows predefined system brightness, and when connect back to AC adapter utility shows brightness in percentage. :wink:

You’re welcome …