How to create a LAN

I’ve recently changed from Ubuntu to Opensuse, and I’m unable to establish a LAN. I had no trouble connecting to the internet with Network Manager, but I am unable to configure the adapter to create a local network.

I have a simple arrangement of 2 computers and 2 wireless multipurpose machines, an HP 8500 Officejet Pro and a Brother 2280DW. All are able to connect to the internet. The computer I want to use as a server and the Brother printer also have a ethernet connections. All the machines operate as they always have. I have diisabled the firewall because I know it is often the source of connection problems.

I’ve consulted the opensuse manual on networking and also the web. I have deactivated wicked and am using only Network Manager.

The manual suggestions all involve steps to take using Network Manager, but the instructions it gives do not produce the results they show. For example, they say a right click on NetworkManager in the Active connections list will enable me to beging making a new network, but all that comes up is two colums of Details with the ability to moe items from one column to another. Same with YAST. All it provides is a settings applet that allows very few changes and no opportunity to make a new connection.

When I try to use the command lines suggested , they don’t work either. for example the command: ifconfig eth0 192.168.0.1 netmask 255.255.255.0 up produces this response
SIOCSIFADDR: No such device
eth0: unknown interface: No such device
SIOCSIFNETMASK: No such device
eth0: unknown interface: No such device

Apparently the advice I’m getting is out of date. I would appreciate it if someone would direct me to a source of current information.

Pleasealway tell which version of openSUSE you use.

I do not quite understand you. When a system has connction to the Internet, that is normaly through a router (provided by your ISP). That means that you have a LAN between that system and the router. By definition. When you the have more systems (computers, printers, etc.) connected to that router, they connect to the same LAN.

LAN means Local Area Network. And that is basicaly a TCP/UP network of systems that all connected to (one side opf) a router and that have IP addrsses in the same range (sub-net).

Also, when your system can connect to the Internet, the network device is alrad configured and functioning. o need to try o do tat again withh ifup (or whhatever).

Please show us:

ifconfig -a

And it my be better to tell what ou want to achieve. What are you doing that gives you the impression that you “have no LAN”?

@rlaconte, welcome to our Forums.

Yes, I’m interested too in finding out what you want/need to do.

I can’t figure out if you simply want to connect the two computers to the internet, or if you want to set up “sharing” between the computers, or if you want to achieve both of those things. Once that’s clear we could also ask what you want to achieve with the two printers (make them printable by both computers perhaps?). You’ve mentioned a “server”. Servers can serve all sorts of things e.g. movies, files, printers, the internet/routing/firewalling etc, so, can you clarify that a bit too please.

Sorry I was vague. I consider my question trivial and most probably answered in some documentation that I haven’t read.

I have 4 devices connected wirelessly to a Netgear Nighthawk AC 1000 smart wifi router which generates a wifi connection called BETRONA . Each of these devices can connect to the internet through that network. However they do not/cannot connect to each other. The NETGEAR Genie program reports that my internet connection is fine but that my WiFI connection is “not enabled.” OpenSUSE, version 13.2, shows both printers in YAST, but only the HP, which is both wired and wireless, prints. The Brother printer is routed to the HP connection and prints anything sent to it on the HP.

Under both Windows 8.1 and Ubuntu the LAN was set up automatically. So I don’t know how to do it manually. That’s why my subject is “How to create a LAN.” Both printers and the other computer show that they are connected to BETRONA, but they are not connected to each other. I’m sure this is just a configuration problem, but I don’t know how to correct it.

By “Server” I meant my desktop computer on whcih openDUSE is installed and has always been the center of LANs I used.

The output for ifconfig -a is

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:390 errors:0 dropped:0 overruns:0 frame:0
TX packets:390 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:126560 (123.5 Kb) TX bytes:126560 (123.5 Kb)

p5p1 Link encap:Ethernet HWaddr C8:1F:66:A8:87:C1
inet addr:192.168.1.9 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:161943 errors:0 dropped:0 overruns:0 frame:0
TX packets:80798 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:133472255 (127.2 Mb) TX bytes:11909180 (11.3 Mb)
Interrupt:17

wlp1s0 Link encap:Ethernet HWaddr 3C:77:E6:80:29:69
inet addr:192.168.1.11 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:70582 errors:0 dropped:0 overruns:0 frame:0
TX packets:653 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:9727606 (9.2 Mb) TX bytes:50642 (49.4 Kb)

Thank you for your assistance.

Ho do you know that there is no connection with other systems? Did you try to ping them?

And please:
Can you please use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

Your ifconfig output shows that you have two network devices (or NICs):
p5p1 is UP and has IP address 192.168.1.9;
wlp1s0 is also UP and has IP address 192.168.1.11.
Mark that the name eth0 is not in use and thus any commands you use pointing to eth0 will fail.

So your LAN is 192.168.1.0/24 and all systems, when hardware (cabll or wifi) connected to the router and having IP addresses in the range 192.168.1.1 - 192.168.1.254 are part of that LAN. And you must be able to ping to them from all of them.

On 2015-04-07 15:36, rlaconte wrote:

> The output for ifconfig -a is
>
> p5p1 Link encap:Ethernet HWaddr C8:1F:66:A8:87:C1
> inet addr:192.168.1.9 Bcast:192.168.1.255 Mask:255.255.255.0
> RX bytes:133472255 (127.2 Mb) TX bytes:11909180 (11.3 Mb)

> wlp1s0 Link encap:Ethernet HWaddr 3C:77:E6:80:29:69
> inet addr:192.168.1.11 Bcast:192.168.1.255
> RX bytes:9727606 (9.2 Mb) TX bytes:50642 (49.4 Kb)

By definition you do have a LAN already. You are connected via cable,
and via wireless. Two simultaneous connections can be problematic. That
cable appears to be the main one (see the Mb received).

Being able to print or share files is something different. It is
something you do on a LAN, but it is different from having a LAN.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Again my apologies for sloppy use of terminology and failure to observe protocol. I understand that ignorance is not an excuse, but it is a reason. I believe this is the first time I have used a forum to ask for technical help, and it is apprent that I don’t know how they work.

Yes, I can ping all the devices, and yes, they are all connected to the same wireless network, along with some other devices such as a smart TV and Roku. I’ve used this arrangement for the past few years with Windows and Ubuntu and have had no problems. My problem at the moment is that, although they are all connected, they are not behaving like a LAN. As I said, Netgear provides a network monitor they call Genie. The network map generated by this monitor normally shows 7 devices connected to the router and provides details such as the MAC address and ip number of each. At present under opensuse it shows only my computer connected to the router with the notation that my wireless network “has not been enabled.” Whether this condition should be identified as lack of a LAN or a malfunctioning LAN is a semantic difference that I did not expect to cause such confusion. My error.

To confirm that all the equipment is functiong as it should, I switched back to Windows, and all is normal–7 devices operating together in a local network. Because this opensuse installation is new, I concluded that somewhere in the process I made and error or an ommision in configuration. I’d like to correct that condition so that the network behaves normally.

When I understand the above, the LAN is there, all it’s member systems are connected and the LAN is OK.

The only thing is that you have some application that tries to report what is on the LAN (with several parameters). Where is that Netgear Genie located? In your oenSUSE system?

BTW, somebody above expressed his surprise that botth your cable and your wifi are connected to the same LAN. I am with him, that that is not correct. Normaly, when the cable is attached, the wifi should be dropped. I am not sure, but that may also explain the problem with your Genie.

On 2015-04-07 21:56, rlaconte wrote:

> Yes, I can ping all the devices, and yes, they are all connected to the
> same wireless network, along with some other devices such as a smart TV
> and Roku. I’ve used this arrangement for the past few years with
> Windows and Ubuntu and have had no problems. My problem at the moment
> is that, although they are all connected, they are not behaving like a
> LAN. As I said, Netgear provides a network monitor they call Genie.
> The network map generated by this monitor normally shows 7 devices
> connected to the router and provides details such as the MAC address and
> ip number of each. At present under opensuse it shows only my computer
> connected to the router with the notation that my wireless network “has
> not been enabled.” Whether this condition should be identified as lack
> of a LAN or a malfunctioning LAN is a semantic difference that I did not
> expect to cause such confusion. My error.

But you see, the command output you pasted before showed that you
apparently have both a wireless and a cable connected, and this can be a
source of problems. If you want to use the WiFi, please disconnect the
cable.

Else, please clarify what is the “p5p1” network interface.

I’m not familiar with that “Genie”, so I can’t comment on what it says.
I’d prefer standard tools like “I can open a share from this client to
that server” or not.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Agreed. I have a LAN. I apologize again for fumbling the terminology.

I have disconnected the cable from my router to my computer. I am now wireless only. I have also disconnected the usb cable from my HP printer so that it is wireless only.

My system now consists of 2 computers and 2 wireless printers, each of which is connected to the internet through my wireless network (named BETRONA).

In this arrangement, according to opensuse, no printers are detected. I cannot print with either printer, nor can I connect to my second computer. I can, however, print using Google Cloud Print, with both machines and also access the internet with my second computer.

If I reboot into Windows 8.1 the entire system works flawlessly. Likewise, when I had Ubuntu installed, everything worked as it should.

What I’d like to know is, how can I make opensuse recognize my network and my other devices?

Again, you have a lot of “I cannot”, but you fail to prove anything.

Please ping those systems from your openSUSE system:

ping -c1 <IP-address>

And of course replace <IP-address> with the respective actual IP addresses.

And post the output here. Bewteen CODE tags (you get them by clicking on the # button in the tool bar of the post editor.

We love to hear your story, but we can only work with hard computer facts.

On Wed 08 Apr 2015 12:46:01 PM CDT, rlaconte wrote:

Agreed. I have a LAN. I apologize again for fumbling the terminology.

I have disconnected the cable from my router to my computer. I am now
wireless only. I have also disconnected the usb cable from my HP
printer so that it is wireless only.

My system now consists of 2 computers and 2 wireless printers, each of
which is connected to the internet through my wireless network (named
BETRONA).

In this arrangement, according to opensuse, no printers are detected. I
cannot print with either printer, nor can I connect to my second
computer. I can, however, print using Google Cloud Print, with both
machines and also access the internet with my second computer.

If I reboot into Windows 8.1 the entire system works flawlessly.
Likewise, when I had Ubuntu installed, everything worked as it should.

What I’d like to know is, how can I make opensuse recognize my network
and my other devices?

Hi
Windows uses netbios for discovery, on openSUSE install hplip and as
root user (not sudo or su, use su -)run the commands and also ensure
cups is running;


systemctl status cups.service
systemctl start cups.service
systemctl enable cups.service
hp-setup

Then in the first screen select the manual discovery and enter the ip
address of the hp wireless printer and press next etc (wait for each
screen before proceeding to the next).

Once printer is added, exit root user and as your user run the command
hp-toolbox and you should be good to go.


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Cups is running. In fact I’ve been looking in their website for a solution. I’ve checked all the settings and, they seem fine.

I installed the hplip driver during the initial opensuse install. Brother has a linux driver for my machine, and I used that. The KDE printer configuration tool shows both printers, but shows no connection for the Brother and only the usb wired connection for the HP (even though I disconnected the cable). The drivers are being recognized but not the connections.

My wireless adapter has been correctly identified in the hardware list, but its function is being ignored as is my router. I’m going to reinstall opensuse, and if the problem persists in the new installation, I’ll simply reinstall ubuntu.

Thank you for your help, and I apologize for having taken up your time on such a trivial matter.

On 2015-04-08 20:56, rlaconte wrote:

> My wireless adapter has been correctly identified in the hardware list,
> but its function is being ignored as is my router. I’m going to
> reinstall opensuse, and if the problem persists in the new installation,
> I’ll simply reinstall ubuntu.

You simply have to do what we asked. Can you ping the printers, router,
and computers, using their address numbers?

Start with that. One problem at a time.

> Thank you for your help, and I apologize for having taken up your time
> on such a trivial matter.

No need to apologize. We are here to try to help.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))