How to connect to a wifi connection that requires a username and password

I’m using openSUSE 13.1 and I’m trying to connect to my schools WiFi but usually when I click on the network in other operating systems a popup comes up asking for my username and password. But with opensuse this doesn’t happen. I also tried to look in the network settings to see if the option for username and password was in there but i couldn’t find one. Can anyone point me in the right direction?

Looking at the network properties in windows I found out that the network has the following settings:
Security type: WPA2-Enterprise
Encryption type: AES
Choose a network authentication method: Microsoft Protected EAP (PEAP)

How are you trying to connect?

Are you using NetworkManager? Is it enabled in YaST->Network Devices->Network Settings->Global Options?
If you connect to a network the first time, a window should appear where you can change the security settings and enter username/password.

Try to click on “Manage Connections”, change to the “Wireless” tab and change the settings there to the ones you posted.

On 2013-11-21, mbish <mbish@no-mx.forums.opensuse.org> wrote:
> I’m using openSUSE 13.1 and I’m trying to connect to my schools WiFi but
> usually when I click on the network in other operating systems a popup
> comes up asking for my username and password. But with opensuse this
> doesn’t happen. I also tried to look in the network settings to see if
> the option for username and password was in there but i couldn’t find
> one. Can anyone point me in the right direction?

Assuming you’re using KDE, press Alt-F2, then type `Network Connections’, and hit Return.

Got it working, had to change authentication type. Thank you.

On 2013-11-21, mbish <mbish@no-mx.forums.opensuse.org> wrote:
>
> I’m using openSUSE 13.1 and I’m trying to connect to my schools WiFi but
> usually when I click on the network in other operating systems a popup
> comes up asking for my username and password. But with opensuse this
> doesn’t happen. I also tried to look in the network settings to see if
> the option for username and password was in there but i couldn’t find
> one. Can anyone point me in the right direction?

Assuming you’re using a laptop with KDE, and using Network Manager rather than traditional ifup to connect, press
Alt-F2, then type `Network Connections’, and hit Return.