How to configure a CMI9761 for 5.1 sorround sound

Hello all, I wonder if somebody could guide/point me to the right direction to configure opensuse 11.1 to play 5.1 audio. The hardware is working fine under windows and mandriva, but got no joy with suse. As per posts that I have seen, I provide you some info so maybe the problem is clear. Thank you.

speaker-test -Dplug:front -c2 -l5 -twav → ok, sound on both speakers

speaker-test -c2 -l5 -twav → ok, sound on both speakers

After executing : wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh , I obteined:

http://www.alsa-project.org/db/?f=05fc2a19cdee8b2b21c958c7cd688876b4b42e8c

rpm -qa | grep alsa , shows:
alsa-oss-1.0.17-1.37
alsa-utils-1.0.18-6.4
alsa-plugins-1.0.18-6.12
alsa-plugins-pulse-1.0.18-6.12
alsa-1.0.18-8.7

rpm -qa | grep pulse , shows:
pulseaudio-0.9.12-9.6
pulseaudio-module-gconf-0.9.12-9.6
pulseaudio-module-lirc-0.9.12-9.6
libxine1-pulse-1.1.16.3-0.pm.2
libpulse-mainloop-glib0-0.9.12-9.6
alsa-plugins-pulse-1.0.18-6.12
libpulse-browse0-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-zeroconf-0.9.12-9.6
libpulse0-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
pulseaudio-module-x11-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6

rpm -q libasound2 , shows:
libasound2-1.0.18-8.7

uname -a is:
Linux clear 2.6.27.21-0.1-pae #1 SMP 2009-03-31 14:50:44 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound , shows:
options snd slots=snd-via82xx

Ssy1.Ygdz0JkHI56:K7VT6 motherboard

alias snd-card-0 snd-via82xx

Any help is welcome, thank you in advance.

Hi pasaporte,

I’m relatively new to 5.1 surround systems, having purchased mine less than a month ago, and having tried it thus far on only two PCs. I documented my experiences with the first PC I tried it on here:
Exploring surround sound in Linux - openSUSE Forums

If I were you, I would take a very close look at your mixer. I highlighted some of your mixer settings below that puzzle me, but I’m not so experienced yet with this, and so you may need to look at more than just what I suggest you examine:

!!Amixer output
!!-------------

!!-------Mixer controls for card 0 [V8237]

Card hw:0 ‘V8237’/‘VIA 8237 with CMI9761A at 0xe400, irq 22’
Mixer name : 'C-Media Electronics CMI9761A ’

**Simple mixer control ‘Master’,0
** Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Front Left: Playback 0 [0%] -46.50dB] [on]
Front Right: Playback 0 [0%] -46.50dB] [on]

**Simple mixer control ‘Surround’,0
** Capabilities: pswitch
Front Left: Playback [off]
Front Right: Playback [off]

Simple mixer control ‘Center’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Mono: Playback 31 [100%] [0.00dB] [off]

Simple mixer control ‘LFE’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Mono: Playback 0 [0%] -46.50dB] [off]

Simple mixer control ‘Channel Mode’,0
Capabilities: enum
Items: ‘2ch’ ‘4ch’ ‘6ch’
Item0: '2ch’

From what I can see of the above, in your PC’s mixer it has surround switched OFF. It has 2 channel instead of 6 channel (for a 5.1) in your PC’s system selected. And your PC has Master and other important volume controls at 0% or muted.

I think (but not sure) that almost certainly will stop surround sound from working. I believe you will need to tune those.

Now for testing your surround sound system, take a look at the tests I tried. For example:
speaker-test -c6 -Dplug:surround51 -t wav -l1

However I found that does not work for my new PC, and I have not figured out why yet. But for my new PC, I found downloading this file:
http://www.halfgaar.net/media/chan-id.zip
and then playing it in vlc and also in mplayer, helped in configuring my 5.1 system on my new PC.

Good luck, and I hope that helps.

Thank you for your response oldcpu:

I’ve made a few changes and it’s working now perfect in alsa, I use gnome and I would like to have it working with pulse audio, the weird thing is that it acts as if it was in 5.1 mode, but it only provides sound on the front speakers, as if , I mean playing the sound speaker test,it plays but only from the front ones, when the lady says right or left rear, it sounds but on the front ones basically.

Here it is the new outcome from the alsa script in case anyone is interested as it works now: http://www.alsa-project.org/db/?f=fb301d68d2f5851e1d8c7bad2f07c15039f48be0

And on the pulse audio issue, any ideas? , I test the sound using kaffeine and I change the settings to test one or the other… weird

Pulseaudio issue sorted, I had to set it up on the pulse configuration, the only thing is that it crashes now and then when I try to set up the differnt channels volume individually. It gives me a message that the sound is busy, any ideas?

I known next to nothing about pulse audio. But crashes don’t read to be proper behaviour.

You could be in bug reporting territory:
Community - PulseAudio - Bug reporting