How to change permissions on external hard drive.

After messing up my laptop running leap 15.3, I am about to reinstall with hopefully a better partition table. Before I do that I want to copy my /home to an external hard drive, whilst I do the installation and return it to the laptop after.

I have purchased a Seagate 1TB portable HDD, which is set up for Windoze. I have format it in Yast, but I am unable to copy to it as it says there isn’t enough space, however I think it is something to do with permissions.

Is it possible to change permissions using a GUI or do I have to use konsole?
Please can someone give me instructions on how to do this. Thank you in advance.

You have :formatted in YaST", but what have you done? Partitioned it or not? Created a file system on it, or on a partition? What type of file system?

And please do not tell stories, but show.
The command you copy with and all the output. We want to see that error message and what you did.

And when you think there is something with permissions, then show the permissions.

I hope this is of more use?

Well, a bit (sore eyes :wink: ).

Better post (as root)

lsblk -f
fdisk -l

And of course you want to do this as system manager (root). Thus it should not be mounted by the desktop of some of the users. In fact when you make a copy of all in /home, there should no normal user be logged in. And you should do that from the CLI login as root.

You seem not be very used to posting computer information here. So, maybe superfluous:
There is an important, but not easy to find feature on the forums.

Please use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

An example is here: Using CODE tags Around your paste.


BTW, I do see information in your fotos. The disk is known as sdb. You made one partition on it (sdb1) and it has an ext4 file system on it. So far so good. But better mount it somewhere else, where it is in the realm of the system and not of some end-user. You can e.g. take /mnt, because it is only for the time being and will be free again after the action.

Unfortunately, the laptop has disconnected from the internet so I am taking photos of the screen. I am not sorting it out as I believe when I do a fresh install of Leap 15.3 it will sort itself out.

I thought when I plugged in the external harddrive it was mounted? In fact I know it is, because when I used the Yast partitioner, it asked me if I wanted to unmount the disk before partitioning. So you want me to mount it somewhere else?
Okay, how do I do that? (specifically)

If it’s a USB connection it should just auto mount under /run/media/<username>?

mount | grep sdb1
/dev/sdb1 on /run/media/username/66245dcf-f349-40b9-ba1e-89e21eddc6fd type ext4 (rw,nosuid,nodev,relatime,errors=remount-ro,uhelper=udisks2)

Bus 001 Device 005: ID 174c:55aa ASMedia Technology Inc. ASM1051E SATA 6Gb/s bridge, ASM1053E SATA 6Gb/s bridge, ASM1153 SATA 3Gb/s bridge, ASM1153E SATA 6Gb/s bridge

If it is formatted as “ext4”, as an earlier comment suggests, then you change permissions as you would for other file systems. After formatting, the root directory of the new disk will be owned by root. You can use “chown” on that if you want it to be for your user files. Of course, you will need root access for that “chown”. But once you have done that, assuming that you yourself are the new directory owner, you should have the access that you want.

Yes it does mount, but I can’t copy anything to it.

I woke up this morning thinking about mounting the hard drive and found this

however I don’t know how to add a line to a file.

Sorry, but the laptop is no longer able to access the internet.

I asked before:

  1. Who is “i” (root or some end-user)?
  2. What thus he/she use to copy?

This is all very vague and does not communicate at all what is done.

And I also repeat:
You want “want to copy my /home to an external hard drive” (as you told in your first post above). That means that you must not be logged in as a any normal user when doing so (that is why question 1). Depending on the way you copy you must even have /home unmounted (if you have a seperate /home file system, which you did not tell) And that is why question 2.

Please, we can not read minds.

Ok, I saw your new two pictures.

So you have a separate /home file system on sda7, size ~110 GB.

sdb1 is ~931 GB. Thus should be large enough.

What is still missing is the command (which tool) you want to use to copy the contents of the one into the other.

I’m really sorry that I don’t understand. I is me? I am the only user. Under normal circumstances I am just a user, then I if I have to use Yast I have to use the administrator password. I opened dolphin and tried to copy the /home to the external drive, I got the message that there wasn’t enough space (I posted photo of it in an earlier reply. I then opened dolphin super user, using my administrators password and tried to copy /home to the external drive, I still got the not enough space message.

I don’t know how to do the copy in Konsole. The fact that I get a message that says there is not enough space when there is 1TB doesn’t make sense to me.

At least with Linux I know it is me that doesn’t understand what is going on rather than Windoze, which is like living with a person crazier than me. Thank you for yoru patience.

I have tried dolphin as a user and as superuser and get the not enough space message.

Hm, this i sgetting a bit difficult.

First, Linux (or any other operating system) does not know “you”. It only knows configurated users. And there are at least 20 of them in your system. The most important is of course root, which is also called “the superuser”. And you say you have created one end-user. Now when you say rather loosely in a post “I did something”, it is not 100% clear which user did that. Mostly it is not clear if it is a end-user or root. Thus most people assume (which is always dangerous and leads to misunderstanding).

So when you say in your first post “I want to copy my /home”, I assume that you mean that as system manager, root, you want to copy all in /home (that may be a separate file system or not). And as /home is not within the responsability of any end-user, but of the system manager, I assumed that you are doing this as root (and I asked you how you tried to do this because many possibilities).

I now get the idea that it is NOT about /home, but in fact about /home/nappy501 and that nappy501 is trying to copy all files in there.

When the latter is the case, then of course user nappy501 must be able to write to (and read from) the directory that user wants to copy to. And, as always in Unix/Linux access is permitted or not by the ownership (by user and group) and the permission bits. This is something you really must have at your fingertips IMHO.

As someone above already mentioned, that directory is now most probably owned by root:root and the permission do not allow normal users access. So, as root, go there and change the owner to nappy501:users (an example, you know who is that user and to what primary group it belongs).

chown nappy501:users /run/media/nappy501/66245dcf-f349-40b9-ba1e-89e21eddc6fd

When you doubt, first look at

ls -l  /run/media/nappy501/66245dcf-f349-40b9-ba1e-89e21eddc6fd

to see what it is now.

If i look at this

i only see “/boot”, “/run”, “/var”, “SWAP”, “/home” and “/BACKUP” but no"/"?

I do not use openSUSE Leap 15.3 nor do i use btrfs so it might be correct that there is no “/”. However could you please tell us which operating system you are using to copy your /home? Is that operating system on your disk /dev/sda or are you using a LIVE-system?



/ is /dev/sda5

Quietly optimistic.