How to change icons of .torrent files?

Yeeeeeeeeehaaaaaaaaaaa! rotfl!

Weel guys, I have a whole bunch of .torrent files which still show the icon from the old kde bittorrent client.
Now what I actually want is to change these to show another icon for better view. I’ve left-clicked these, tabbed ‘properties’, but from there it’s not possible to change the icon as I would normaly do anywhere…

Any hints appreciated.


Do you actually mean ‘right click - properties’?

That would be the way to go

click on the icon in the first box and select the icon you want from the list

Yeah, that’s what I actually meant. I right-click, chose properties tab - and usually it just takes a click on the icon from there to get to chose another symbol… seems not to work for .torrent-files.


Now what I did was to search for those pictures used as icons and replaced them by resized pictures of vuze - and it worked.
Somehow all my work disappeared after upgrading to the latest KDE 4.2.1 - I wonder if that has something to do with the mime-files?

Certainly this standard torrent icon doesn´t look good at all.


Well guys, I still have the “issue” and by now I know that it´s related to the *.torrent-mimetype.

All I want to accomplish is that ALL *.torrent files permanently show the frog used by VUZE and not the standart logo´s of x-bittorrent.

Is there some application I need to uninstall to get rid of all of the other torrent filepictures?
Would be awesome if someone would gimme a nudge on this one… :wink:


Glad I searched, it saved me starting a new thread.
Basically the same problem, but not just torrent files, with any file it is seemingly impossible to change the icon. You used to be able to do it in file associations, bring up the file association eg .doc and change the icon for that particular associated file type, or via properties of a particular file, but you can no longer do that. There is no ‘clickability’ to the icon raised in file associations or in properties. The icon for an application can be changed via properties but not a file type.

And here’s finally the solution for ANY file association:

  1. Open Konqueror (Computer) from Desktop.
  2. Click “Settings”
  3. Navigate to “Change Konqueror’s settings” → File Associations
  4. Search the filetype that you want to be changed in the search bar
  5. Click the appropriate filetype that pops up in the window on the left
  6. Change anything you want. Think before you act. :wink: