How to change default Wifi connection?

I have two available wifi connections in my house (2.4 GHz and 5GHz), but oS keeps defaulting to connecting to the 2G connection. I have to manually switch to the 5G channel every boot - each time I do it asks for root password and also the wifi password - so it’s not remembering the wifi password although I’m entering it every time.

Any ideas? :sarcastic:

You don’t say which desktop you are using but in KDE there is an option to make a wi-fi connection available to all users. In this case, I am reasonably sure that it takes precedence.

If a KDE Desktop system is using Network Manager then, the “All Users” option is normally only used for the physical Ethernet port.
The authentication required for WLAN SSIDs is usually managed by KWallet; if KWallet hasn’t been initialised then the Network Manager can not use KWallet to store the per SSID authentication data.
My current working view is, all attempts to initialise KWallet during the Network Manager set-up of WLAN SSID parameters and authentication, are doomed to failure.

Your post sounds very much like you are still using your default network management settings which configures you to use Wicked and installs but does not enable Networkmanager. Wicked can only remember the one network connection and if you change to another WiFi AP, the previous settings are lost. Also, Wicked requires you to provide root authentication to configure.

You need to open the following to switch from Wicked to Networkmanager
YAST > Network Devices > “General” tab

After that,
You should be able to rt-click on the Network Manager applet in your “tray” (the right most collection of icons in your taskbar) and configure individual network connections.


Sorry for the delayed reply, I was away from my computer for a few days.

I am running KDE and using Network Manager. It remembers the 2G wifi password and always defaults to connecting to this on boot. However, when I connect to the 5G SSID, it promts for root password followed by the WPA key. So it has managed to store and remember the 2G one, but for some reason when switching it doesn’t remember.

When I try to updated the connection details, it says “Failed to get secrets for connection - no agents were available for this request”…

Verify <every> setting,
It can be a very easy overlooked setting, like what cipher to use.
And, once configured (incorrectly) it may be continually resetting. Delete the problem connection completely and start over.


I tried that, also tried deleting the other connection so there is only the 5G one to connect to. It still insists on asking for root password followed by WPA key on boot. Really not sure what I’m missing here. Just as a test, I installed Linux Mint 18 and the network manager had no issues remembering the the key or defaulting to the 5G connection. I wonder whether it is to do with Kwallet or something like that since Mint was using Cinnamon DE…

Maybe there’s a misunderstanding about Leap 42.1 Network Manager security: in /etc/NetworkManager/system-connections/ there are files, one per WLAN SSID user definition, (plus one for the “everyone” Ethernet definition), which are owned by the ‘root’ user and have only ‘root’ user access – no group; no world . . .

  • Leap 42.1 does not normally require that “normal” users need to know the “root” user password before they can add additional WLAN SSID Network Manager definitions – the Network Manager is normally running with sufficient privileges to be able to write the files belonging to the “root” user in the /etc/ sub-directory.

An example of one of the WLAN files (30 lines) is [some pieces have been changed to “not for publication”]:






Only if you haven’t initialised KWallet before you began to feed it with WLAN SSID passwords.

(This is from memory. I’m not current running NetworkManager, so I cannot easily check).

Edit the connection (via the NetworkManager tray icon).

Make sure that the connect is set to be shared by all users (I think that’s the leftmost tab).

Then go to the tab for security/authentication. Look for the place where you enter the network key. You may need to re-enter the key at this point.

At the right end of that key entry slot, there should be two icons. But maybe you can only see one. So maximize that window. Or, if the window is already maximized, the unmaximize it. (The change is size “fixes” a bug). You should now see two icons. One of those allows you to set where the network key is saved. Go with the option to save unencrypted and available to all users. (That may sound scary, but it is saved in a file that is only readable by root).

You will be prompted for the root password to save those changes. After that, kwallet won’t be used for the connection.

Hmm, you should be able to set the 2G connection to not “automatically connect” and the 5G connection to automatically connect. (Changing that setting might require the root password, too). Then it should behave as you want.