How to auto start vmware service?

every time I reboot the box, I have to run:
sudo /etc/init.d/vmware start

in order to start the vmware support processes.

There are entries in /etc/init.d/rc5.d
lrwxrwxrwx 1 root root 18 2010-06-08 18:08 K08vmware -> /etc/init.d/vmware
lrwxrwxrwx 1 root root 18 2010-06-08 18:08 S19vmware -> /etc/init.d/vmware

So, I do not know why it won’t start upon boot time.

It is minor annoyance but it would be nice if I can fix it as I run VMware quite often.

Thanks.

Hi
Have you checked in YaST->System->System Services (runlevels), select
the ‘expert’ radio button to see if it’s all enabled. Else from the
command line;


/sbin/chkconfig vmware

If off;

sudo /sbin/chkconfig vmware on


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
up 0:17, 2 users, load average: 0.11, 0.40, 0.32
GPU GeForce 8600 GTS Silent - Driver Version: 195.36.31

I looked at them. and it is all enabled, checked through command line and it is turned on. I do not know why. According to system services, vmware is currently running, but when I try vmware player, it says /dev/vmmon does not exists. I have to run the vmware service manually.

Hi
So from the command line after a reboot, if you try;


sudo /etc/init.d/vmware status
ps -ef |grep vm

You should see then loaded and running?


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
up 18:09, 2 users, load average: 0.21, 0.09, 0.02
GPU GeForce 8600 GTS Silent - Driver Version: 195.36.31

stranger@linux-mwos:~> sudo /etc/init.d/vmware status
root's password:
Module vmmon not loaded
Module vmnet not loaded
stranger@linux-mwos:~> ps -ef|grep vm
stranger  6563  3442  0 07:47 pts/3    00:00:00 grep vm
stranger@linux-mwos:~>

It appears not.

Has anyone make any progress on this? Its still a problem.

I have nearly the identical situation; it’s like S19vmware isn’t run or is otherwise broken. I can’t find any error messages or warnings from any related scripts…the vmware service just doesn’t start after any system start.

Came here looking after having the same exact issue. openSUSE 11.3 with VMware Workstation 7.1.2 installed.

service vmware status lists vmmon and vmnet as not loaded. However, System Services in YAST has the service as running (currently) and at boot. If I ‘service vmware restart’ all is well.

As a temporary workaround, I added ‘service vmware restart’ to /etc/rc.d/boot.local and I’m good to go every boot.

Sure would love to know why this happens…

Thanks!

Fixed ::

Considering how much time I spent on this tonight… pretty simple fix:

VMware KB: VMware Workstation fails to load when restarting a SUSE Linux host after the initial installation

Works fine after setting the runlevel to 5 only. Interesting how VMware has allowed this little issue to linger for so long (note how the KB article started with openSUSE 10.

I just got the same issiue on Debian Squeeze and VMware-Workstation-Full-7.1.4-385536.i386.bundle (/etc/init.d/vmware not started after reboot). My solution was to replace the soft links in /etc/rc[235].d/S19vmware pointing to the absolute path /etc/init.d/vmware with relative links to …/init.d/vmware .

Same problem with VMware workstation 7.1.4 build-385536 but as the link to the KB stated, removing the ‘vmware’ service from runlevels 2 and 3 solved the problem. Also other USB devices showed up after the reboot. Those devices didn’t work before.

thanks burgeke
your temporary workaround worked for me after many hours search over few days. I will adopt your solution as permanent.
Problem was that Workstation could not find vmmom and I was always needed to start it manually. It happened after a fresh Kubuntu 14.04 installation with Workstation 10.0. I put ‘service vmware restart’ in /etc/rc.local however.

If systemd is in play and you want to load the modules on boot then you can have a look at **systemd-modules-load.service(8)
**or rather run, (This is systemd version 208 which you can find in openSUSE 13.1)

man 8 systemd-modules-load.service

Older openSUSE versions check out /etc/sysconfig/kernel, edit that file but please make sure you make a backup :-). You will need to run mkinitrd for that to take effect. Just a suggestion since i’m not using vmware :wink:

FYI, 13.1 there is no more LOAD_MODULES_ON_BOOT entry or something similar in that file.

You can probably create your own systemd unit file for vmware :), also if vmmon module is not a kernel module then please ignore my last post :shame:

On 2014-05-09 10:16, jetchisel wrote:
>
> If systemd is in play and you want to load the modules on boot then you
> can have a look at *systemd-modules-load.service(8)
> *or rather run,

With vmware player, which is very similar to workstation, start on boot
works automatically with systemd. However, there is a problem when you
try to activate it (“systemctl enable vmware.service” or “chkconfig
vmware on”), both hit a bug somewhere. You have instead to use “insserv”
directly instead.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))