How to add a Desktop Environment to my CLI intsall?

Hi all,

I previously asked this question but got conflicting info and it didn’t work in the end.

What I did: Installed XFCE Desktop environment pattern via YaST. It kinda worked but not completely and was not very stable. So I removed everything. I then tried to install the KDE pattern to no avail.
See thread: http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/479735-installing-x-textonly-opensuse.html

Could someone please provide a step by step method for adding a Desktop Environment to a CLI install of OpenSuSE 12.2? My knowledge is too limited to do this myself, I’m pretty sure I’m not alone in that situation and it would help a few people.

Thanks,

Installing the pattern(s) for a DE should be enough, it should pull in the X server as well. After that you may have to configure the default runlevel.

I am not sure. It is perfectly valid to run DE using remote X terminal, in which case X server is not required on a system where DE is installed. Looking at package list for e.g. pattern kde4 - I do not see anything that pulls in X server.

If all you want is to install a DE from the cli, just use zypper to install the pattern. As root:


# zypper in -t pattern kde4
# zypper in -t pattern lxde
# zypper in -t pattern xfce
# zypper in -t pattern lxde

Why are you doing a cli ‘install’? I assume the “x11” pattern wasn’t installed in this case. Do you intend to use the DE locally or remotely. If locally, you should install the x11 pattern as well:

# zypper in -t pattern x11

As @arvidjaar noticed, I don’t see that x11 get installed with a DE pattern.

I tried with a DE pattern and it wasn’t enough to get it working.

RIght now, I have a CLI only system. I would like to add a GUI to it because I need to run a program that is graphical only.

I am looking for a functional way to accomplish this, with a pattern or otherwise.

You should install the x11 pattern (at least) as well

If you need a GUI, why didn’t you just install a DE during setup? Sounds silly, but it would have worked.

Hi
What does “wasn’t enough to get it working” mean? Did you configure the windowmanager and displaymanager for the Desktop Environment (or check they are configured). Did you run init 5 to start the Desktop login?

Is this a server, if you have another system running an X server? If so you can always ssh -X onto the system and run there.

Maybe a simple window manager like spectrwm (or the many others) if you just want some sort of X environment that can just start from you user command line after you login.

Or is your system video driver an issue, more details on specifics, Xorg logs and ~/.xsession-errors will help. Note for logs and such use SUSE Paste set the expiry to never and post the link back.

Very least you might want:
basic desktop pattern such as: (patterns-openSUSE-xfce_basis)
display manager (lightdm)
terminal emulator (xterm)

After install:
Install yast2-runlevel, and run yast2, go to services/runlevel and expert mode, and make sure it is set to level 5 (multi-user with display manager). Next install yast2-sysconfig and go to the sysconfig editor in yast. Then search for displaym and there should be a section called displaymanager with value xdm. Set it to lightdm instead. After reboot you should have login screen and set session to xfce and you have xfce available for login.

In retrospect, I should have. I didn’t think I would need one so I skipped it because I wanted to keep my install as light as possible.

In the list, I don’t have lightdm even though I installed it in yast as per your instructions. I have kdm, xdm, gdm, wdm, console and the default is set to <blank>

On 2012-11-04 18:46, ShaolinSatellite wrote:

> In the list, I don’t have lightdm even though I installed it in yast as
> per your instructions. I have kdm, xdm, gdm, wdm, console and the
> default is set to <blank>

So, choose one and write it there.

The process is basically to install the X11 pattern and at least a
desktop pattern. Then you have to do whatever Yast would have done to
configure it all.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” (Minas Tirith))

If you want to keep the install “as light as possible”, you don’t need to install a DE, but you have to install the x11 pattern if you want to run a GUI application locally. Xorg itself doesn’t require a desktop environment and comes with a default window manager, called twm. You can give it an acceptable look and feel, but it requires some work and a solid knowledge of its configuration: ImageShack - Best place for all of your image hosting and image sharing needs

I would recommend installing lxde though. Your application might not work on barebone Xorg if it needs other programs or libraries.

This doesn’t work. When I restart, it shows this gree bar to say openSuSe is booting and it stays stuck when the bar is full. I have to press Ctrl Alt F1 to get a console (with green text instead of white like before).

I went back to setting the default runlevel to 3; reverted to default options in YaST config manager (<blank> in windowmanager) and rebooted the system. Now it boots back into CLI but I have no graphical interface.

Have you tried booting in recovery (formerly failsafe) mode? (Just in case it’s a driver-related issue.)

You have to type type lightdm manually to make it work. It only appear in when you default install LXDE/Xfce, If you replace it and would like to revert back to lightdm you have to manually type it.