How may I download but not install .xpi

Hi,I am trying to download an .xpi add-on for T’bird using Firefox. I want to download and save the file but Firefox thinks I want to install it on Firefox and then it aborts the process and erases the download because the download is not compatible. How may I turn off this automatic behaviour so I can just save the .xpi file please?[INDENT=3] [/INDENT]

KDE Desktop with Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

Please ignore. I have it now!!!

Determine the URL of the download (various ways possible including web browser Developer console, web page, more).

Then, use something other than Firefox(another web browser, wget) to download the file.


I don’t think this is something the openSUSE community can solve, since this is a plain Mozilla upstream issue. IMO there should be some option in about:config, if not the Mozilla devs have blocked this thoroughly.

right click on the xpi link and select save link as
it should allow you to save the xpi (this has worked for me on the mozilla addons site)