How do I stop the screen from going black every 10 min or so?

I like to watch youtube.com

I’m on a JFK assassination binge right now

Every ten minutes or so the screen goes blank and I have to hit the keyboard or wiggle the mouse to bring it back to life

This isn’t hibernation…for the audio still works

I’ve looked around the control center…right clicked the desktop and looked at options there

I can’t fix this…and its really starting to annoy me

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

disable the screensaver


VampirD
No in elenath hîlar nan hâd gîn
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

iEYEARECAAYFAkt9yK4ACgkQJQ+0ABWtaVlGuQCffb0AY0PPlf9VehRaRc+EUxiH
pOkAn0sjCiqixCJYt52fPYlom/cZLlr3
=pdtK
-----END PGP SIGNATURE-----

check your screen saver settings. by default it’s set to run every 7 minutes. it drove me mad the first time i installed openSuse.
:wink:

I’ve seen thus but do not have a fix. What it is is the kernel screen blanker. I never managed get it to turn off. It is interesting in that when a running screen saver is tunning it doe not blank. But let ten min pass with out input and no screen saver active and the !@#$ screen blanker kicks in.

Linux disable screen blanking i.e. preventing screen going blank

this may help but I never go to to work in 10.1 and 10.2

I have not noticed the problem in 11.2

I see it happening on 11.3M1&2. My screensaver is enabled and set for ‘polygons’ at 15 minutes. I also turned power devil off but that didn’t help.

Try this:

System Settings -> Display -> Power Control

and set the controls as you want. Or just disable display power management.

I think you can disable display power management globally through sax2.

Paul

OK this is insane!!! Here I am w/ my 3 or 4 day old install of SuSe 12.1 KDE and I can not for the life of me stop system sounds and more importantly…MUCH MORE IMPORTANTLY…I can not stop the screen from going black every 10 min or so!!!

Its driving me insane

Seriously seriously seriously!!! If I have to spend 3 days looking through all the controls over and over and over again…and google research this…and use the native help and I STILL DON’T HAVE AN ANSWER? Then that means KDE is NOT USER FRIENDLY AND HAS FAILED MISERABLY!!!

I’m so annoyed I’m thinking of just switching back to Windows 7

On 2012-07-22 14:16, kaneandrew1 wrote:
>
> OK this is insane!!! Here I am w/ my 3 or 4 day old install of SuSe
> 12.1 KDE

Then please do not reuse a 2 years old thread with solutions that do not apply to your version.

Here you have a thread with your problem and a solution.
View this thread here

There are many hundreds more you can search for.

> I’m so annoyed I’m thinking of just switching back to Windows 7

With that attitude you will not last long here :slight_smile:

There is a step learning curve ahead of you, and you have to endure it, and it will take time.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

In KDE there is another setting that, if not present, can allow your screen to go blank. There are three places that can cause this in KDE:

  1. Screen Saver Settings: Menu / Configure Desktop / Hardware /** Display and Monitor** / Screen Saver
  2. Power Settings: Menu / Configure Desktop / Hardware / Power Management
  3. KDE Screen Saver Settings in kscreensaverrc:

Edit the file (in the hidden $HOME folder) ~/.kde4/share/config/kscreensaverrc as a normal user (not as root!)

[ScreenSaver]
PlasmaEnabled=true
Saver=glmatrix.desktop
Timeout=600
DPMS-dependent=false

Add the setting DPMS-dependent=false at the bottom to any other existing entries which will be based on your screen saver settings. This setting can apparently only be added manually as shown in this example. Log out and back into KDE for the setting to take effect immediately.

Thank You,

I see you’re a newcomer just like me, I’ve been using openSUSE 12.1 for less than month, yes I have stumbled upon so many problems, but its crucial to be patient and willing to learn to be able to enjoy this OS. Forum is definitely your friend, I’ve good so much of my questions answered here. This is of course unlike Windows 7, I hardly needed any forum help to solve my problems, but that also prevented me from learning so much. It’s just a matter of how well you search here for answers, anyway will post here if I could find solution to your problem. :wink:

On 07/23/2012 02:56 PM, havock07 wrote:
>
> kaneandrew1;2475767 Wrote:
>> I’m so annoyed I’m thinking of just switching back to Windows 7
>
> I see you’re a newcomer just like me, I’ve been using openSUSE 12.1 for
> less than month, yes I have stumbled upon so many problems, but its
> crucial to be patient and willing to learn to be able to enjoy this OS.
> Forum is definitely your friend, I’ve good so much of my questions
> answered here. This is of course unlike Windows 7, I hardly needed any
> forum help to solve my problems, but that also prevented me from
> learning so much. It’s just a matter of how well you search here for
> answers, anyway will post here if I could find solution to your problem.

I don’t know how to make the change from a GUI, but it can be done from a
program. I use MythTV and TvTime, and both disable both the screensaver and the
blanking. The command to do it is “xset -dpms s off”. To restore both, “xset
+dpms s on”.

If I needed to set this up for myself, I would create a file named watchvideo.sh
with the following contents:


#!/bin/sh
xset -dpms s off
<command_to_run_the_video_program>
xset +dpms s on

Next make the file be executable with “chmod a+x watchvideo.sh”. Because my
natural preference is to use the command line, I don’t know how to create a
desktop icon to launch this script; however, I’m certain someone else will know
how to do that.

WINDOWS 7 IS THE BEST lol!:Protfl!

WINDOWS 7 IS THE BEST

use what works for you…

or learn a new system…look into Configure Desktop > Power Management
and set the controls there as you want them…also check that Configure
Desktop > Display and Monitor > Screen Saver is as you want it…


dd http://tinyurl.com/DD-Caveat

This was meant as a joke in the spirit of the thread. That’s to neg-reping me for no good reason.

On 01/19/2013 06:06 PM, bananaosx wrote:
> This was meant as a joke in the spirit of the thread.

i’m not laughing . . .

> That’s to neg-reping me for no good reason.

i’ve not neg-reped you (or anyone else i can think of, for years! as far
as i remember the last one was a Finnish witch, who was banned for life)…


dd
openSUSE®, the “German Engineered Automobile” of operating systems!

Your neg. number has been removed and you may continue on as normal.

Thank You,