how do I shutdown X Server?

I am trying to install NVIDIA proprietary drivers in the hope that WoW will play versus installing flawlessly, launching the cinematic and then crashing!


Uh, I need to shutdown the X server in order to do this and I searched via the internet and came up with:

killall -# X

Niether of these killed X. Instead for the first I got a message saying there are no processes called X and the second I got a system beep while in tty7 but I also tried it as root in tty2.

My next attempt was to killall -l in order to find the name of the X process, but I didn’t see a recognizable name as X Server or X11 or even Xorg there was xcpu and xfsz but as I’m unsure if these are the appropriate processes I didn’t mess with them.

I also tried logging out of my user environment and switching to tty2 to do these things, but apparently the logon window still requires X.

I also tried killall -#### where # is the PID of KDE4, but it didn’t offer anything except a NOPE! YOU’RE WRONG!

So… can someone perhaps provide me with the steps to shutting down the X server, or even better booting to the command line which I tried to edit /etc/inittab to do but despite using (esc):w! /etc/inittab it didn’t save my changes and continued to boot to level 5. I might even ask if I move the boot process to level 3 will I be able to start X with startx or will it require some more knowledge than your typical welcome to Linux we are easy to use too tactics? OpenSUSE has been anything but what I learned in Linux OS thus far with the issues which have arisen, but this is besides the point.

Okay, thanks!

P.S. I also sifted through the FAQ and old posts on this forum, techguy (which is where I got some options), and Linux Questions but was unable to find an exact matching issue which had a resolution therein. Thanks again!

You need to hit C-A-B twice in quick succession. You shouldn’t do this except in an emergency because you lose app state. If you can shutdown normally, temporarily boot to level 3 next time by adding 3 to the boot options on the splash screen.

ok tyvm. i’m going to give this a shot right now and get back to you as soon as i can see the results, I’ll try both methods.

CAB in twice rapid succession just logged me out of my present login.

and as for passing boot arguments for run level 3, I know how to do it with vi (like I said I just can’t get it to save for some wierd reason), but I don’t know the syntax for a boot argument. I was thinking it would be something like xorg=off or no; but I haven’t been able to find a boot argument article that was written for this OpenSUSE distribution (only 8.x or RH6; etc.).

Think you could pass a wink?

Passing a :wink: lol!

Press ctrl+alt+F1 and login as root user and run;

init 3

You can edit the /etc/inittab and change the default runlevel from 5 to
3 in the following line;

# The default runlevel is defined here

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 21 days 15:12, 4 users, load average: 0.64, 0.31, 0.34
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15

you sir or miss, are a saint! it worked like a charm! tyvm!!

as a matter of fact I noticed you are using a GEForce card! This is precisely why I needed to shutdown X, in order to install the NVIDIA driver.

Might I ask?

I got the driver to begin installation but then it stops saying I have no precompiled kernel interface, asks if it should build a module, and then fails at building the module. It said I needed --source, --devel, and --source packages for the kernel installed and so I did that and got the same outcome.

Do you think you can help me out with that? I can move the post over to hardware if necessary, insofar as beginning a new post! I don’t want to tick off the administrators of the website.

ftdstrange wrote:
> CAB in twice rapid succession just logged me out of my present login.

when IN Xwindows and you do a Ctrl+Alt+Backspace twice in rapid
succession it kills X (i did not say it shutsdown X, it MURDERS it
brutally)…i never knew before now what happens if you are in X,
and Ctrl+Alt+F1 to a terminal, sign in and THEN Ctrl+Alt+Backspace
(while NOT in X)…but, now i do it: logs you out (i guess, i’ve not
tried it)…

HOWEVER: (as mentioned) Ctrl+Alt+Backspace is not the best way to
shutdown Xwindows…in fact is one of the worst ways–but it works and
imo should only be used if all kinder and more controlled shutdowns
are not available (the easiest, imo, if in KDE/Gnome/etc DE, right
click desktop, choose “Log Out [ID]” > “End Current Session” which
will shutdown X and present a log in screen where you can log back in
OR log in as a different user OR in the “Sessions” menu (lower left)
find other desktop environments you may want to try, as well as (as
i recall–i can’t look and TYPE) you can choose a terminal session or
something like that…which, when you get there you can log into the
command line session and there will be no X running, it having be
kindly shutdown in a controlled and normal manner)

but back to your original question: you need to shut down X to install
nVidia driver? i don’t think so…at least i didn’t easily find the
step in saying “Shutdown X”

big hint: linux has been around for a long time and the internet is
FULL of how-tos, tips, hints, and step-by-steps that were wonderful
for another distro, a long time ago…but, if followed by you today
it may or may not either work okay or destroy your system…

if at all possible always try to find answers that apply to openSUSE
at least, and if at all possible to the version you are using
(things move VERY fast around here…)

one way to find openSUSE answers is to search only by
using google’s site specifier, like this string will: install nvidia drivers

that search finds all in the wiki AND the forum…this just in the forum: install nvidia drivers

another site worth searching is which you might
find populated with stuff that usually requires more advanced
knowledge to follow (assumes you are a programmer, like most (all?)
the folks posting there)

as a rule, i’d suggest to always search for openSUSE specific answers
first…actually, may first suggestion is to find the answer in
provided documentation and if unsuccessful then search site
specific…and, only then search wider…

can find the documentation? review a previous message of mine at

-=welcome=- lots to learn here, take your time…

DenverD (Linux Counter 282315)
posted via NNTP w/TBird | KDE 3.5.7 | openSUSE 10.3 SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

Can you provide the output of:

rpm -qa '*kernel*'

alright, I read your caveat so I see the personality in the capslock button but as someone whose eyesight is depleting yet his stupidity won’t permit him to quit using this ****ed lcd screen that’s as bright as a star (gaseous fiery some ***** that’s bound to implode one day), for the love of god use the Bold format lol! Thanks again, I actually posted in the Nvidia forums on this as the information to quit x server was specified by Nvidia that created the driver. MMM…if you like you can check it out at the Nvidia website; however I might have downloaded the wrong driver on a second look to get the web address for you, fate has it good!

anyhow, thanks again I wrote down the information you provided and will hopefully retain it. >:)

whoever this cyberbully is needs an @$$ whoooopin’!

be it ghost, bit, byte, or NO!

the darndest thing: opening super user konsole and typing init 3 only works when it wants to? on top of that, I download the correct NVIDIA driver, and low and behold, it isn’t listed in the folder it is in!

I say fire the comptroller and it ain’t me obviously!


this is the output of rpm -qa kernel

its the wierdest thing though, my desktop theme keeps changing! and whereas one login I’m logged in automatically to my user account despite it having a password, and other times I have to enter a password, even still other times I am logged in as root which is when the desktop theme changes?

from looking at that information I’m assuming that the noarch packages are unneccessary as my kernel is x86_64?

as for the file download, it is in the /home/download folder of root and as root, it won’t always permit me to use the init 3 function described above.

so the issue is as such now (as its evolved virally)

On using the system it was buggy as per other posts
Logins changed from automatic throughput to password required
From user account to root
Files are downloading either to user account /home/download or root
init 3 function or command is accessible more readily as user than as root
it makes sense in an odd way, the main issue at the time then is to stop the changing of account logins from blowing through my password or logging me in as root or user. Could this have to do with the boot option I select? I have bounced between two but the initial chosen one is the one I’m using now, the Desktop option and it has been as user account or root at its own discretion!
What’s really going on (I mean as much as I would like to resolve these other issues the account variances are going to provide a huge annoyance for obvious reasons; let alone that I can’t seem to cd into the /home/root/Download folder in the same manner as I can the /home/user/Download folder?

I guess that’s what reptiles have to do with puzzled penguins, perhaps I should learn Python!

Please, why have you installed both kernel-desktop and kernel-default. When you build the graphic driver it will ONLY work against one of those kernels and the other will be broken for proprietary graphics. Is that what you want? HOW did those multiple kernels get installed? That is NOT what nominally happens.

Logged on as root to your desktop? Thats a VERY BAD idea. Its a classic newbie mistake. You can completely mess up your permissions badly that way, so much that I seriously doubt I know enough to solve such problems resulting. Do NOT login as root to your desktop.

If you feel this is necessary, I’ll leave this thread, as I noted I do not have the expertise to help users who mess up their system permissions by loging in to their desktop as root.

No. That assumption is inaccurate. noarch packages can be necessary. All it means is the same packaged rpm can be used for both 32-bit and 64-bit architecture (ie noarch) and their is no need to package separate rpms for both.

alright I figured out the root/user account thing so pardon my idiocy. Apparently it logs into the user account either boot option chosen, but starting run level 3 and logging in as root, then using startx places me in the GUI environment for root. I don’t know why I didn’t put two and two together on that one! :’(

It is weird though that I can’t shutdown in root? It allows for suspend to disk, ram, switch, lock, and logout but logging out brings me to a screen prompting for the root password and places me back in root as does switching users, which doesn’t make sense.

haha, jokes on me.

ftdstrange wrote:
> for the love of god use the Bold format lol!

for the love of all that is good, you use what you like and i’ll use
what i like…

i normally neither post nor read using http so such things as bold,
italics, underline, text color and other means to highlight
“important” to note and/or not miss words is left to my active

if YOU don’t like my methods, sorry…but, i won’t be switching to
http just to use [BOLD]bold[/BOLD] format… :slight_smile:

DenverD (Linux Counter 282315)
posted via NNTP w/TBird | KDE 3.5.7 | openSUSE 10.3 SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

so if you don’t use a browser to post then how do you? ssh?

@oldcpu okay thankyou for that, I suppose I knew that but the logic was that there is a noarch kernel and having not used it specifically noarch configured kernel packages might conflict, but as it is inaccurate this is also irrelevant.

however, You seem to have been addressing my issue regarding the Nvidia driver. Thankyou. I just realized that every instance of driver I have downloaded is not even for my graphics card, yet I was able to install the Nvidia control applications.

They do suggest I install the x driver and run nvidia-xconfig but this command is seen as a typo in konsole. What have I done wrong as Nvidia doesn’t elaborate much.

I noticed another wierd thing, both the box and the boot information see my card as a 512 mb GPU, but according to the websites by galaxy and nvidia its a 256mb 64bit gpu.