How do I rotate the Grub screen?

I have a GPD MicroPC and during boot, Grub is rotated 90 degrees. With the “fbcon=rotate:1” kernel boot option, the Linux boot portion is rotated properly though. Is there away to rotate the Grub portion of the boot?

Yesterday, when the kernel got updated, a blue pop-up showed up but it was rotated and half the content was cut off. I don’t even know what the screen was for since half it was missing. Good thing after just waiting, it transitioned to the regular encryption passphrase screen.

Thank you.

I don’t know how to rotate the grub screen. But the blue pop-up was asking whether you agree to adding a key certificate to MokManager. And if you agree it will ask for a password (should be the root password). This has to do with secure-boot and UEFI.

Thanks for clarifying what the blue screen was. I guess it still shows up even though I have secure boot disabled in the BIOS/UEFI settings.

It’d be nice if I can figure out a way to rotate the Grub screen. I guess it’s not possible.

Nothing in the BIOS??

Does the boot splash screen show right??

Unfortunately, there isn’t anything in the BIOS for screen rotation. I’m not sure which stage you mean by “boot splash” so I’ll describe the screen orientation at the various stages.
[li]BIOS/UEFI POST where the GPD logo shows:[/li][ul]
[li]Correct orientation [/li][/ul]

[li]Passphrase for /boot decryption:[/li][ul]
[li]90 degrees rotated [/li][/ul]

[li]Grub menu to select booting Tumbleweed:[/li][ul]
[li]90 degrees rotated [/li][/ul]

[li]Tumbleweed boot splash screen[/li][ul]
[li]90 degrees rotated [/li][li]Pressing a key to show the boot messages:[/li][LIST]
[li]Correct orientation due to “fbcon=rotate:1” kernel boot parameter [/li][/ul]


[li]Xfce login and desktop:[/li][ul]
[li]Correct orientation [/li][/ul]


So it’s stages 2 and 3 (both is Grub, right?) are what I want to rotate.

Thank you.

What is the GPU? Some Intel video chip?

What is the Resolution setting in grub? (Yast-Boot Loader). If auto try changing

There are many internet threads on this …

I note for example: grub - Rotate console on startup (Debian) - Unix & Linux Stack Exchange

You may need to add video=efifb to ensure that the framebuffer console is used: GRUB_CMDLINE_LINUX=“video=efifb fbcon=rotate:1”
EDIT: The efifb driver is designed for EFI firmware only, especially Intel-based Apple computers. However, as I’ve found out, it also works for non-Apple PCs. I am running the proprietary nVidia drivers on my Linux system, and the efifb driver works quite well. I assume it works for me because I am using nVidia drivers, and the “native” fbdev driver conflicts with them.

I have no idea if that will work, nor if it will make it worse. I get the sense there could also be graphic driver dependency issues here.

Edit: you may wish to read further in that link above (ie the comments) as there were comments on that proposed solution to qualify its ability to function further.

Thanks for the suggestions.

  • Yes, it’s an Intel GPU that’s part of the N4100 SoC. Looks to be “UHD Graphics 600”.
  • In the Yast > Boot Loader window, the resolution was set to auto. Setting it to 800x600 or 600x800 didn’t change the orientation.

Thanks for the response. However, I already have the “fbcon=rotate:1” Linux kernel boot arg. This rotates the console boot and vttty properly. See stage 4 from my last post.

This setting only applies to Linux and not Grub. I’m trying to figure out how to rotate the Grub screen. I’ve already figured out the Linux console and Xorg rotation before creating this thread.

Thank you.

Yes I read that … The point was “video=efifb”

I assume now you also tried “video=efifb” and it made no difference, or made it worse.

Yes, I did try that parameter as well. I actually got the “fbcon=rotate:1” parameter from that exact StackExchange thread. Since “video=efifb” made no difference, I only kept the “fbcon=rotate:1” parameter.

Thank you.

ok … too bad it does not work. One silly question (on my part), and I note this is far from my area of expertise. What grub2 command did you send after applying both of those settings to ensure grub updated ( ie updated after applying the “video=efifb” and “fbcon=rotate:1” ) ?

After adding those args to the GRUB_CMDLINE_LINUX line (ie. GRUB_CMDLINE_LINUX=“fbcon=rotate:1”) in /etc/default/grub, I ran

sudo grub2-mkconfig -o /boot/grub2/grub.cfg 

I got that command from the first line in /etc/default/grub.

After that, the Linux console/vtty was properly rotated so I figured it only applies to Linux since Grub itself is still rotated by 90 degrees (it’s a Linux boot arg afterall).

Thank you.

I assume you really meant to type you added

GRUB_CMDLINE_LINUX="video=efifb fbcon=rotate:1"

and sent the ‘sudo grub2-mkconfig -o /boot/grub2/grub.cfg’ command. That had no effect after a reboot, so you removed the “video=efifb” but left in the “fbcon=rotate:1”

My reading suggests the “video=efifb” works for some, but not for all, wrt rotating grub2 menu, and I suspect there are graphic card aspects and BIOS aspects here as well that influence the result.

I tried both
GRUB_CMDLINE_LINUX="video=efifb fbcon=rotate:1"

with sudo grub2-mkconfig -o /boot/grub2/grub.cfg + reboot for both.

Both had the same effect where they rotated the Linux console/vtty screens properly. Without them, the console/vtty (ie. Ctrl+Alt+F1) was rotated by 90 degrees. Since fbcon=rotate:1 alone rotated the Linux console (ie. video=efifb did nothing), I kept only that.

These only affect Linux but not Grub itself. While the Linux console/vtty are now rotated properly, the Grub screen is still rotated by 90 degrees.

I agree that there’s probably some BIOS or hardware specific issue but there doesn’t seem to be software fix.

I am not aware of any official grub2 update. I did read of a case where one user claimed to have modified the grub2 source code, recompiled, and then succeeded in rotating the grub2 menu … but it was a bit advanced for myself, and apologies, but I did not keep the link. Edit: I recall also the detail the user provided was fuzzy and I was skeptical if actually worked.

Modifying source code and compiling is too advanced for me as well. For now, I can live with Grub being rotated.

Thank you.