How do I Install GNOME from Command?

I posted this 1st in the wrong forum so Sorry for the duplicate.

I have a Suse 13.2 VM in Hyper-V with minimal install that boots to the command line. I want to boot into GNOME.

After some Googling I went into Yast2 Software and installed Patterns for GNOME Desktop Environment and GNOME Base System.

After reboot it still comes to the command prompt to login. I tried startx but it returns an error and it seems that is depreciated? So I tried Init 5. It runs through and starts loading things then stops at “Started Local Service.” and hangs there.

I have used Suse/SLES over the years but always with GNOME.

How to I get GNOME running?



is gdm installed and configured

Yes. When I look in Yast2 Software I see gdm The GNOME Display Manager as well as gdm-branding-openSUSE default configuration.

I am replying here since I posted in what was probably the wrong forum at first

You were correct that the DISPLAYMANAGER=“gdb” was not set. I did that in vi and restarted. Came back to command logon, When I run init 5 now something flashes on the screen quickly and then I am back at the command line with no errors or feedback.

No KDI or GHOME if that is what you mean. Yast2 is a blue dos looking menu. This was a mail filtering appliance build by someone else which has much better suse skills than I.

"this might be a silly response but do you have a display manager installed and configured?
in yast /etc/sysconfig editor make sure gdm is set as a display manager.

or edit /etc/sysconfig/displaymanager
and set DISPLAYMANAGER=“gdm”
ps. you only have a command line no graphical user interface at all?"

do you have any sort of graphical interface?
being installed in yast does not mean it’s configured
while in yast go to /etc/sysconfig editor and setup your display manager (set gdm) or edit
/etc/sysconfig/displaymanager and set

When I go into Yast there is no /etc/. Only Software, System, Hardware, Network Devices, Network Services, Users and Sec, Support, Misc.

FYI previously before setting DISPLAYMANAGER=“gdm” when I tried access from VNC I got a gray screen that when away and said Oops. Now I get a black screen with a small circle for the mouse.

Thanks for the Help!

it’s a separate module called etc/sysconfig editor, you can still use vi or other text editors, see the content of
$vi /etc/sysconfig/displaymanager
I believe that the display manager field has been set console and that’s your problem, change it to gdm
if you can’t use vi google it, it is a strange text editor (you need to press insert to edit text, and when all is done :w to write the changes) I can’t think of another simple console text editor

here’s a screen shot of etc/sysconfig in ncurses
it’s easier then learning vi

Sorry if I am missing something.

I did use vi as I mentioned earlier and you were correct that DISPLAYMANAGER=“gdb” was missing, it was DISPLAYMANAGER="". So I added gdm and rebooted. Now it still comes back to the command line logon. When I try init 5 something passes over the screen quickly and returns to the prompt, no errors.

Before adding the displaymanger setting when I tried to VNC to the box I got a gray screen, then an error that said Oops, now I get a black screen with a circle for the mouse. So adding the displaymanger setting has changed something but I still am not getting GNOME.

In Yast under System there is no /etc/sysconfig editor. My menu is different and only shows 5 things, Boot Loader, Date & Time etc…


Does that VM support openGL? Gnome absolutely requires full openGL support. You may need to see if that Windows VM requires a guest video driver or something. What you saw flash buy was gnome complaining of insufficient video capability

You might try KDE or one of the light weight desktops instead they are not as demanding

From my reading Hyper-V 2012 supports openGL.

How would I tell if there is an appropriate driver installed in the VM?

gnome does need 3d acceleration, but I think gdm should run fine without it, I think you are missing some shared objects like messa or X libraries and you may figure out what those are I’d suggest reinstalling with lxdm (or gnome), why lxdm it’s small and does not need 3d you can add gnome latter. As it is a virtual machine it might be quicker to reinstall.
Or you can try and install some of the meta packages that may provide the needed libraries

sudo zypper in patterns-openSUSE-x11 gnome

the above gnome should be patterns-openSUSE-gnome

sudo zypper in patterns-openSUSE-x11 patterns-openSUSE-gnome

zypper in patterns-openSUSE-x11 patterns-openSUSE-gnome

Already installed, reporst Nothing to do.

sorry I didn’t quite understand this but, does gdm show up and the system crashes during gnome start-up or gdm doesn’t work aether?
if gdm works and gnome does not it’s a driver issue that only microsoft can fix see this
and get the drivers from ms here

if gdm works and you don’t want to mess wiith ms driivers install mate (it is a gnome2 fork and doesn’t need acceleration)

sudo zypper in gnome-main-menu mate-backgrounds mate-control-center mate-dialogs caja mate-icon-theme mate-notification-daemon mate-polkit marco mate-session-manager mate-settings-daemon mate-desktop mate-panel caja-image-converter caja-open-terminal caja-sendto caja-share dconf-editor mate-dictionary mate-disk-usage-analyzer mate-icon-theme-faenza mate-netspeed mate-screenshot mate-search-tool mate-sensors-applet mate-system-log mate-user-share mozo python-caja atril engrampa eom gucharmap mate-applets mate-calc mate-power-manager mate-media mate-screensaver mate-system-monitor mate-terminal mate-themes mate-menus atril-caja caja-engrampa marco-themes mate-common mate-icon-theme-faenza-dark mate-icon-theme-faenza-gray mate-indicator-applet patterns-openSUSE-mate_basis pluma lightdm

I know it’s a long list try installing only the meta packages

sudo zypper in patterns-openSUSE-mate patterns-openSUSE-mate_basis patterns-openSUSE-mate_admin 

or install lxdm (another gtk2 based desktop environment)

While it is true that GNOME needs full openGL support, it should work fine with Mesa’s software renderer if the video driver doesn’t support openGL.
It might be slow, but it should run.

A problem is when the driver announces openGL support, but it is incomplete/buggy though.

Try to boot to “Recovery Mode” as a test, this should use a generic driver with Mesa’s software renderer for openGL.
I have no idea though what video driver Hyper-V would use in the guest.

Well, try to disable it if possible.

How would I tell if there is an appropriate driver installed in the VM?

“glxinfo | grep render”, or hwinfo --gfxcard

I suppose you mean lxde, right?
lxdm is a displaymanager, no desktop environment… :wink:

If gdm does not work, lxdm would be an alternative though, or kdm or lightdm.
You can/have to set the displaymanager in /etc/sysconfig/displaymanager (variable DISPLAYMANAGER) with a text editor or YaST after you installed it, as already mentioned earlier.
You could set it to xdm as well, which should be installed by default, to get a GUI at least. But as GNOME probably doesn’t work either, you should also set the default windowmanager (DEFAULT_WM in /etc/sysconfig/windowmanager) to something else too (icewm should be installed by default).