How do I get MB1/MB2 = MB3 operation to work?

I have upgraded three systems to OpenSUSE 12.2 and the first two went pretty smoothly so I was confident enough to proceed with a 3rd system – my primary system for 99% of my work. I saw no errors during the installation but post-install I found that I do not have the ability to emulate MB3 by chording MB1 and MB2. That means I now have to go through 4-5 mouse clicks to cut and paste text in most applications where, previously, it was possible to merely select text and use MB3 to paste it into another location/window. Cutting and pasting in a terminal window or between windows is a major pain now. “xman” is a major pain to use now since you are completely unable to do the “smooth scrolling” that MB3 allowed. The first two systems I upgraded do not have this problem. MB3 emulation used to work on 11.x and, heck, all flavors of Linux that I’ve used since the mid-90s. I’ve reinstalled on my primary system twice since first discovering this on the chance that the hardware detection was at fault or that instlalaing using images (or not) might be causing the installation to screw up when selecting what software to use for the mouse. “hwinfo” does find the correct mouse (Kensington trackball) so I’m fairly convinced that the problem is not the result of some odd failure occurring during the hardware detection phase of the install. Of course, if anyone has something that’ll convince me otherwise, I’m all ears. There’s nothing in the desktop configuraton, YaST, or anything else that seems to address this. This is a serious workflow problem. Hopefully there’s a simple solution.

Any ideas?



On Thu, 28 Feb 2013 22:56:03 +0000, rnturner wrote:

> Any ideas?

Which desktop are you using?


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at

Sorry 'bout that… KDE 4.8.5

For those who are as innocent as I am: MB seems to mean “mouse button”.

Before there was a third mouse button people who have 2 hands do this which is pretty darn fast…
Right hand - Operate Mouse, using left clicks only to set “the focus”
Left hand - Execute keyboard shortcuts for copy, paste, cut.

Copy - Ctl-C
Paste - Ctl-V
Cut - Ctl-X

Select all between previous Cursor position and current Cursor position - Ctl-shift-Click

For the <real> traditionals, they don’t even use the mouse. Using the right hand to press the arrow buttons, plus using the tab key to shift between windows and functions, they do it all with the keyboard (I prefer not to, but is sometimes necessary operating a remote terminal).

As for you missing third mouse button functionality, maybe something here might help
xorg - Configuring mouse for right+left button simulating middle click (for copy/paste) - Unix and Linux


Real traditionals never heard of Ctrl-V and consorts. They copied/pasted using left en middle mouse button even before Windows was created.

On 02/28/2013 11:56 PM, rnturner wrote:
> Any ideas?

I’m testing 12.3 with XFCE, and traditional X copy paste works. I use
third mouse button emulation via clicking both buttons simultaneously
(it is a laptop touchpad).

Carlos E. R. (12.3 Dartmouth test at Minas-Anor9

I have no problem with chording the mouse buttons on my Dell Inspiron. It’s my primary desktop that is misbehaving.

Bingo! Oh, I’ve /heard/ of those shortcuts alright. But the way my mouse is working now reminds me of Windows and I can’t tell how painful it is to watch Windows users jump through all the hoops that their UI forces upon them to cut and paste in terminal windows. And you’re right… even back in the days of DOS, my trusty Logitech bus mouse had a working paste function with the middle button.

I’ll take a look at the Xorg suggestion. I haven’t looked at that link yet but I’m assuming it will involve using xmodmap to tweak the button assignments. (It been so long since I’ve messed around with that utility that I can’t remember why I needed to though I /am/ sure it wasn’t on a Linux system and I’m pretty sure it wasn’t mouse-related.)

I’ll post my results.

On 03/01/2013 11:16 PM, hcvv wrote:
> Real traditionals never heard of Ctrl-V

i never heard of using Ctrl+V until i saw it pop up here in questions…

[in OS/2 Warp i always used Ctrl+Insert and Shift+Insert, i don’t
remember what i used in the 16 bit Win3 that came on my first
machine…until i wiped it out and installed Warp’s 32 bit,
multitasking multiuser enterprise level system.]


Getting closer… (I think)

I found on 12.2 that the mouse button definitions are a bit odd. The buttons reported by “xev” are lower-left = “button 1”, lower-right = “button 3” (?), upper-left = “button 2”, and upper-right = “button 9”. The last one is especially odd since there’s only four buttons on the mouse. I was able to boot the system using the old 11.x system and the mouse buttons were defined the same (still seems odd) with the exception of the upper-right button which didn’t report anything when I tested it with “xev”. And even weirder, I found that the upper-left button by itself seems to work as a middle button. Unfortunately, the position of that button means that you need to use both hands to press the button and operate the trackball. (I just can’t contort my right hand alone to where I can press the button and scroll. :^( )

Now back when I was running 11.x, Xorg was using the “mouse” driver and everything was working fine but the 12.2 release is using “evdev”. Also, back under 11.x, the protocol being specified for the mouse was “explorerps/2”. The new Xorg seems to want to use “ThinkingMouse” which is definitely not the same mouse as the Expert Mouse. (Perhaps electrically they are/were but ergonomically they are light years different.) So… I tried switching the driver from “evdev” to “mouse” in /etc/X11/xorg.cond.d/11-mouse.conf to no avail. The entries in Xorg.0.log and what it reported using the output of “xinput list” and “xinput list-props” shows that the driver is still “evdev”. There is a driver called “” under /usr/lib/xorg/modules/input but I can’t seem to get Xorg to use it. All of the changes I’ve attempted to make to “11-mouse.conf” are either being ignored or are being overridden by something else. I haven’t been able to figure out what would be overriding the changes I’m making or where the file containing the overrides is located. I’ve scoured the Xorg.0.log and don’t see anything in the config files that it says it’s reading that seem to be messing with the mouse.

I’ll try again tomorrow with a finer-toothed comb – and, if possible, starting Xorg with the “-verbose” switch to get more details as to what’s happening during startup – but in the mean time… any thoughts?



I was previously thinking that perhaps the “evdev” driver was buggy when used with the Expert Mouse but everything I read about the “evdev” and “mouse” drivers led me to conclude that the “mouse” driver is only included with Xorg for Linux systems that are fairly old. There were some, IMO, conflicting statements about whether “evdev” would be used depending on whether “udev” and/or “hald” were being used. Or not.

Anyway, I had added “Option ‘Emulate3Buttons’ ‘on’” to the “11-mouse.conf” file (seems logical, right? We’re trying to control something regarding the mouse) under /etc/X11/xorg.conf.d and was tearing my hair out wondering why nothing was having any effect. I stumbled across another web site that mentioned adding that line to the “10-evdev.conf” instead. That finally did the trick though it still isn’t clear why that option needs to be in that particular file.

That is a systemV init script, a logical place for configuring daemons and invoking special sub-systems rather than your original location which sounds like is for configurations for standard hardware functionality.


Take a look at Systemsettings - Shortcuts and Gestures. Don’t have a mouse available, but IIRC you can set the alternate key to the mouse button desired.

BTW, in terminals you can “mouse select” then use Ctrl-Shift-C/V instead of Ctrl-C/V.

On 2013-03-05 11:16, Knurpht wrote:
> BTW, in terminals you can “mouse select” then use Ctrl-Shift-C/V
> instead of Ctrl-C/V.

Not, for example, in xterm terminal :slight_smile:

Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))