How do I get latest rpms from

I’m looking at factory ncurses. It says last build was 9 days ago. I see file changed 5 days ago. I tried branching and building, but the resulting rpms did not seem to contain the claimed fix. I have not really ever used this build system before.

You should just be able to install the relevant files direct from Base:System rather than branching? Or be patient and wait for them to come through in due course.

Since you branched the package and built, you need to;

a) Set the branch to publish (disabled by default), see all X’s
b) Add your repo and zypper dup from it.

Well I can download directly and install manually too. None of it worked, I’ll just delete the branch. I suspect they’ll have to revisit the fix.

Why do you need an RPM, particularly if you’re looking for something bleeding edge (My guess is that you’d use it only as long as until a regular distribution version is available).

You can download the latest released binary from the main project (you can skim the notes to see if your bug fix is in it)

Or, try the latest Beta release

The above are upstream, anything in OBS would be a downstream patch.


I personally recompiled ncurses and cfdisk from source, and it worked. But seems like openSUSE maintainers can’t duplicate it, only crashing cfdisk.