How do I disable KDE3 Network Manager

Hello, I am a newbie here, this is my first post so please go easy on me :slight_smile:

Currently I’m using opensuse 11.1 32-bit, on my laptop (specs later)

since i just updated KDE to 4.2.4, I now have KDE4 network manager installed. The question is, how do I disable KDE3 Network manager, and if needed, how do I set up the KDE4 network manager so it can detect wireless (and wired) natively just like KDE3 one does.

Thanks in advance.

ah here is my machine specs, in case somebody need it.

Just uninstall it

zypper rm  NetworkManager-kde

or try disabling it in Config Desktop, Advanced, Autostart
(But I find this a temperamental config section)

thank you mr caf4926 for quick response… i never thought to uninstall it, since uninstalling something usually yields troubles… but in this case, it works…

now what i need to do is to automate the connecting process everytime i login… for now i have to manually double click the conection from personal settings > network management > wireless… anybody know which application to add in autostart? i tried to find knetworkmanager in /usr/bin and /usr/share but there is none…](

sorry for long delay… I got pretty busy at college.

Actually I have checked it, but I still have to double-click everytime I want to connect. It even ask for wallet password. I have clicked always allow, and even added kwalletd into autostart, but still no autoconnect…

In Yast - Network Settings
Are you set to use networkmanager or traditional ifup?

What version of kwallet, I mean is it for kde4?

I don’t know if its fixed yet, but the whole kwallet issue annoyed me away from the KDE NetworkManager. I installed wicd and never looked back.

One of the things I love about linux is you can try stuff like this risk-free. Dont’ like it? Toss it and try something else! :wink:

Which is certainly the case for Networkmanager for KDE4, there are a lot of issues, Kwallet for one, and the fact that it just doesn’t work, in my case anyway. I spent two, separate, days trying to get it to work. Started to lose the will to live, and then tossed it it and put WICD in its place, which works well, auto connects and everything that NM should do but doesn’t. I only mention this as it is often difficult to get wireless sorted at the best of times but when the thingo you are using to do it is actually broken then you are on a hiding to nothing.

Same as Prexy: switched to WICD and never felt the need to go back to the Networkmanager. For me, WICD does all the things that Networkmanager should do.

I have been using the kde4 NetworkManager now for a month or so and I have no problem whatsoever. kwallet came up the first time I used it, but now I never see it. I use knode and kwallet asks for pass when I check messages there.

Haven’t found any proof yet, but from last couple of weeks I don’t see troubles on 32bit laptops. On 64bit, from what it feels like, it works/does not work after install, next update reverses that, next update reverses last. On and off. Don’t mind about that on my own laptop, but others might just update and be stuck with an uncooperative Networkmanager.

Same here, 64 bit OS 11.0, KDE 3.5/4.2(at the time, now 4.3). knm worked for some time, until I started to use it in alternating wireless networks. After much trying I changed to wicd a couple months ago and it have been working flawlessly.