How do i configure YAST to work with a proxy?

I work with a proxy server. When i try to update my system i am not being allowed access. it tells me that i am denied access. what can i do?

YaST > Network Services > Proxy

Thank you for your response. When i try to configure the proxy as you suggested and test the connection I get the error message: "An error occurred during the HTTP proxy test.
Proxy return code: HTTP/1.0 407 Proxy Authentication Required.
Proxy auth using Basic with user …
> GET http:// --proxy-user user:password HTTP/1.1

> Proxy-Authorization: Basic
> User-Agent: curl/7.19.0 (i686-suse-linux-gnu) libcurl/7.19.0 OpenSSL/0.9.8h zlib/1.2.3 libidn/1.10

> Host: --proxy-user user:password
> Pragma: no-cache

> Accept: /
"

The authentication is rejected. Does it have to do with the type of authentication? How can I fix this if possible?

Thank you again.

Kieron

Did you configure the username and password also? What sort of proxy do you have? AFAIK that YaST authentication setup only works with basic HTTP authentication. If you have a proxy that requires Windows domain authentication, I’m not sure YaST can handle it, but don’t take my word for it, as fortunately I don’t have to deal with such proxies.

I did use a correct username and password. The authentication is basic. I don’t think it uses windows authentication since the server is Linux based.

See if you can use curl manually from the command line with the proxy iser and password option:

curl -U user:password http://www.example.com/somedocument.html

I am having the same problem…
Can you suggest some solution.
I can access internet through firefox using proxy server but other applications are not able to connect to the internet.

I believe it’s a bug in there somewhere, but this is how i got it to work… 1) open yast and locate proxy under network settings, 2) check “enable Proxy”… now this is where it’s not obvious… the proxy window has a proxy settings group and a proxy authentication group. Even if you put your credentials into the authentication group, it does not get written to the proxy file located at “/etc/sysconfig/proxy”, to do this you need to add the credentials before the http:// address… this must be done in the format: http://username: password@proxyaddress: port for all proxy entries in there. thus if my username was Josh and my password was 16B3, then you must put in all the entries in the proxy settings group http://Josh:16B3@10.0.0.3:8080… finally put the username and password into the proxy authentication group, test the settings, it should work, click ok, re-login and yast will work. Other proxy apps that depend on system settings should also work… I cant say this technique will work for you, but it worked for me… my PC is running openSUSE 11.4 using GNOME(pronounced Ge-Nome) window manager… one more thing, the proxy can be a name like “proxy.school.com” it doesnt have to be an ip address… thats it…

OpenSUSE 13.1 x64, year 2014

Still an unsolved mistery. Why system proxy settings doesn’t work for someone of OpenSUSE users?

Does nobody know why the “Test” try to access to Novell’s site?

  • Rebuilt URL to: http://www.novell.com/

  • About to connect() to proxy 10.0.0.1 port 3128 (#0)

  • Trying 10.0.0.1…

  • Adding handle: conn: 0xcb8b40

  • Adding handle: send: 0

  • Adding handle: recv: 0

  • Curl_addHandleToPipeline: length: 1

    • Conn 0 (0xcb8b40) send_pipe: 1, recv_pipe: 0
      % Total % Received % Xferd Average Speed Time Time Time Current
      Dload Upload Total Spent Left Speed

    0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0* Connected to 10.0.0.1 (10.0.0.1) port 3128 (#0)

  • Proxy auth using Basic with user ‘mi_usuario’
    > GET http://www.novell.com/ HTTP/1.1
    > Proxy-Authorization: Basic MTQwMDpybXJjWTAwNDE=
    > User-Agent: curl/7.32.0
    > Host: www.novell.com
    > Accept: /
    > Proxy-Connection: Keep-Alive
    >

  • HTTP 1.0, assume close after body
    < HTTP/1.0 301 Moved Permanently
    < Date: Wed, 02 Apr 2014 11:21:10 GMT
    < Server: Apache
    < Location: http://www.novell.com/home/
    < Content-Length: 319
    < Age: 13
    < X-Mag: 679880B1B4350226;5f1b2030;9237385;usrLkup->0;usrBase->0;getPRBefFind->0;getPRBefFind->0;PRAfterFind->0;www_root;publicURL->0;FP4->0;
    < Content-Type: text/html; charset=iso-8859-1
    < Set-Cookie: lb_novell=NOODEBIJ; Domain=.novell.com; Path=/
    < X-Cache: MISS from Kraken
    < X-Cache-Lookup: MISS from Kraken:3128
    < Via: 1.1 www.novell.com (Access Gateway-ag-679880B1B4350226-9237385), 1.0 Kraken (squid/3.1.20)

  • HTTP/1.0 connection set to keep alive!
    < Connection: keep-alive
    <
    { [data not shown]

100 319 100 319 0 0 518 0 --:–:-- --:–:-- --:–:-- 518
100 319 100 319 0 0 518 0 --:–:-- --:–:-- --:–:-- 518

  • Connection #0 to host 10.0.0.1 left intact
    I wish some day someone will throw light on this.

:wink:

This works for me. Thank you!!!

From bash:

export http_proxy=http://username@pword@proxy.thing.com:8080/
export https_proxy=$http_proxy
export ftp_proxy=$http_proxy
export rsync_proxy=$http_proxy
export no_proxy=“localhost,127.0.0.1,localaddress,.localdomain.com”

You can also specify user/password combinations if needed, as well as the port number. I usually set the
proxies through YaST, but with some software, the command-line exports seem to be required
(Can someone please double-check my syntax here?)

From bash:

export http_proxy=http://username:password@proxy.thing.com:8080/
export https_proxy=$http_proxy
export ftp_proxy=$http_proxy
export rsync_proxy=$http_proxy
export no_proxy=“localhost,127.0.0.1,localaddress,.localdomain.com”

You can also specify user/password combinations if needed, as well as the port number. I usually set the proxies through YaST, but with some software, the command-line exports seem to be *required
(Can someone please double-check my syntax here?)