How do I adjust the DPI on my laptop display?

Hello all.
I have an HP Elitebook 8470P laptop running a newly installed LEAP 42.1 & Plasma5
It has a ~14" display with a 1600x900 resolution.

KInfoCenter reports a 96x96 DPI for the monitor, but I calculate that I need more like 130x130 DPI.

I’ve tried adjusting the system font size, and that seems to help for KDE applications, not so much for LibreOffice, Firefox, Thunderbird, etc.

I’ve also tried using the scaling option in system settings->display manager, but after the required restart, nothing seems to change.

I’ve read elsewhere on the forum that a custom Xorg.conf won’t help, as it gets ignored when Kscreen is running.

So, what do I need to do to get the DPI for my display set at what it needs to be?

I’d really like a 10pt font to look like a 10pt font, not a 7pt font.

Thank you,

Additional information on DPI can be found here:
Firefox and Thunderbird have to be edited individually using about:config and adjusting scale factor.

When using kscreen increase the scale factor to 2.

Follow Up

Though some issues still prevail , KDE plasma 5 provides a decent support for HiDPI screens .
Please follow these guidelines for HiDPI support in KDE plasma 5:

  1. Increase font dpi (System Settings → Font → Force font dpi, enter a number such as 125, 144 or 150 etc)
  2. Change Scale ( System Settings → Display and Monitor → Display Configuration → Scale Display , scroll to value 2 )

Firefox addon for increasing DPI:

Thank you Romanator, for the link and subsequent follow-up.

I apologize for not replying sooner, but celebrating my wife’s birthday got in the way.:slight_smile:

When I first looked at the ArchWiki, I thought the the 2 steps were 2 different options of achieving the same goal, so I tried the force font dpi with the scaling back at 1 (since it hadn’t effected any change). Unfortunately, that didn’t work either.

It was only after I though about it a bit more that I decided to try both scaling AND force font dpi. I set the font dpi to 130 and the scaling to 1.4 (a rough approximation of the ratio of 96:130). That helped quite a bit.

I then brought up Kruler and set the cursor at 130 pixels and laid a scale against the screen. I measured a bit under 1". Adjusting the scaling to 1.5 got 130 pixels even closer to an inch, so I’m on the right track.

A bit more fiddling around, and I’m confident that what I see on the screen will be a very close approximation to reality.

I realize that I can adjust the font size in Firefox and Thunderbird, but at least in Thunderbird that only affects the font size of outgoing mail. It also does nothing for LibreOffice, WireShark, etc.

Curiously, the X-Server tab on KInfoCenter still shows a 96dpi screen of 423 x 238 mm (the actual dimensions are more like 309 x 174 mm). I assume that this is caused by poor communication between X-Server and KScreen2, due to a bug in one or the other (or both). Is this worthy of a bug report?

At any rate, thank you for pointing me in the right direction. it is very much appreciated.


My external monitor should be 1900x1200 on 17" but I can only activate 1600x1050. So everything is to big and would like higher dpi on the external monitor. The dpi for the notebook screen is 1920x1200@15"
Is there a way to adjust the dpi for the external monitor?

Navigate to systemsettings5 -> Display and use kscreen.
Kscreen was designed for users using an extra monitor.

You should see to adjust and sync up the laptop with the external monitor.

Kscreen is running great in KDE4. I would keep my eye on kscreen in Plasma 5. If it’s giving your grief, try renaming .local/share/kscreen and reboot.
I highly encourage you to submit a bug report if you keep encountering problems. The sooner we come across these issues the sooner we can get them patched.

Keep a notepad next to you when you are making changes to keep track :wink:

Good Luck!