How did wine get this far?

It official, wine rules. After a lot of media attention for the new web 2.0 browser flock a decided to take it for a spin. As a matter of fact I am creating this thread using Flock on SuSE 11 KDE 4.1.

But not the linux download. I tried, but got discouraged by the following message after downloading, unpacking and trying it to start…

./flock-bin: error while loading shared libraries: cannot open shared object file: No such file or directory

So I boldly took the change and just clicked on this little flag representing the Redmond (windows) version. After downloading the slightly bigger windows version a popup followed, after that a installation wizard. It suggested to make desktop and menu entry’s and it did.

This is not the fist app that I found, installs better in wine than plain linux. Have you ever tried to install mplayer without the packman repositories? I did and it took me several hours whereas installing the windows binary takes about 5 minutes. True, cutting and pasting is a bit more difficult and some fonts are not as fancy as in the Linux versions but at least wine gives me the opportunity to test some software without hours of dependency checking.

I use the OpenSuse repositories for almost all my software. I can’t remember the last time I had trouble installing a program due to dependency issues, it has been a while

Wine has come a long way though in the last few years

hmm, just downloaded flock & it works no problem, i use only linux,no wine or windows :wink:


zypper in compat-libstdc++

And your Linux flock works fine. (Takes about 2 seconds to install on 11.0 - far cry from those ‘hours’)

All you need is “compat-libstdc++” package from “OSS” repository.

Still doesn’t seem to do USB very well…or at all.

wow, this

sudo zypper in compat-libstdc++

actually does work. The guy’s at Flock need to know about this. Thanx.

Now I’ll try to find out and understand how I can figured out which compat I need to install next time an install fails.

Greetings. Resturp

strangles people who use sudo

**su -c ‘zypper in compat-libstdc++’ **

deltaflyer44 wrote:
> hmm, just downloaded flock & it works no problem, i use only linux,no
> wine or windows :wink:

i also installed flock on a pure linux machine with no problems at all…i did
it so i could figure out how to help a newer to linux user in one of these suse
fora to get his/hers installed…

i really didn’t like it a lot better than firefox (flock is just a customized
FF) so deleted it, but i think the other user got hers/his installed using my
postings…perhaps you can search for that thread and get yours going without
wine also…

NOT, that using wine is a bad thing…just in the flock example it is not
necessary since flock IS opensource…

DenverD (Linux Counter 282315)
A Texan in Denmark

Gee… guess you could make yourself a profession out of that then :wink:

> strangles people who use sudo

Ubuntu started the craze I think.

Hmmmm shouldn’t you use

su - -c ''

so you load root’s profile preventing you from accidentally running a version of zypper that is not in root’s path?

sorry Chrysantine you are absolutely right.

su -c does create a root shell and thus loads root’s profile.
sudo does not and therefore imposes an potential security risk.

let me clarify for those who miss the point.

try the following:

start a terminal and do:

touch bin/cat
chmod +x bin/cat
cat /etc/fstab
man su

What happen???
We created a empty script cat that does absolutely nothing.
when we now try to cat a file, as ~/bin comes first in a normal users PATH setting, nothing happens.

when we try to read a man page the man system uses cat to pickup the correct file so therefore the man command fails.

Now within the same session try:

su -c 'cat /etc/fstab'
sudo 'cat /etc/fstab'

You see, the users version of the cat program gets used by root. we obviously don’t want this to happen as it imposes security and stability trouble.

Thank you Chrysantine for pointing this out.