How can I login from terminal as user with no password?

I removed the password from my user account but despite GDM logging me in automatically, if I switch to a virtual terminal I am unable to login there. How can I login? On Fedora, I believe I could enter anything for a password on a passwordless account and be permitted entry.

OR… How can I have the gnome lock screen stop prompting me for my password when I unlock the device? (I actually like the lock screen as it display the notifications which have occurred while I was away, I just don’t want to enter a password)


Login as root user and reset your user password.

passwd <username>

Do you want the system to auto login or have to enter a password to login?

For a password at the lock screen, go to system settings -> privacy and select screen lock to off, it won’t prompt for a password.

Yes, I’ve removed the password with “passwd -d”, but I can no longer login as that user from a terminal. I would like to have no password required to login.

You need to look at pam to create a config to turn off the password requirement, in the interim, just reset your user password from the root user account, then set to autologin to the desktop, then change that privacy setting for the screen lock. Then can look at a passwordless login.

Yes, turning off screen lock works for the most part, I just sort of liked how Gnome presented all of my notifications in a full screen manner on the lock screen when I returned to the machine. So I wanted the lock screen but no password when unlocking (which is the behavior when the password is removed, but then I can’t login from a terminal).

Hmmm what your saying doesn’t make sense, if you turn off the privacy option, then you will not be asked for a password to return to your desktop (unlock the screen). If you don’t want a password to enter a terminal/console session that is different and needs some pam work for this to occur (not very wise from a security point of view).

If I turn off the privacy option, the lock screen never appears and I remain at my desktop. I wanted the gnome lock screen but no password required to close it. It’s not a big deal, just a preference.

Thanks for your help!

So you have changed something else (I get the shade/lock screen), look under System Settings -> Power and that Dim screen is on and blank screen is set if you like. Then when you wiggle the mouse it should unblank the screen and remain at the shade…

To manually activate, press Super+L or on the upside down triangle (top right) hit the padlock button… but this requires a password…