how can I install /usr/lib64/

I’m trying to build / work with
in Qt Creator.

When I try to open the project and select its Cmake file,
it asks me to run cmake… so I do…
and it gives an error

CMake Error at /home/username/Qt/5.6/gcc_64/lib/cmake/Qt5Gui/Qt5GuiConfig.cmake:15 (message):
  The imported target "Qt5::Gui" references the file


  but this file does not exist.

I have confirmed this file doesn’t exist.
When I search for libegl in yast,
it shows I have everything installed except a 32 bit devel package.

The 64 bit Tumbleweed link gives an error here

How can I install /usr/lib64/

Install Mesa-libEGL-devel.

To answer such questions for yourself in the future, you can also use “zypper wp”:

wolfi@amiga:~> zypper wp /usr/lib64/
Command 'what-provides' is replaced by 'search --provides --match-exact'.
See 'help search' for all available options.
Loading repository data...
Reading installed packages...

S | Name              | Summary                           | Type   
i | Mesa-libEGL-devel | Development files for the EGL API | package

I am currently on 13.2 though, in later versions you probably should do as the message says, i.e. something like:

zypper search --provides --match-exact /usr/lib64/

Or you can probably just omit the “–match-exact” as well, depending on your needs… :wink:

See also: “zypper search --help” (or also “zypper --help”). zypper does have a very comprehensive online help.

Thanks for the information!

I ended up fixing their .pro file :cool:
And it doesn’t seem to matter that I don’t have /usr/lib64/

I already had that installed.

However, /usr/lib64/ does not exist

What does:

Reading failure… it does exist! ;-] is a “symbolic link” is a “shared library”

Is this to be expected?

Creator (cmake) still claims the file doesn’t exist.

libgegl is not libegl, you haven’t installed Mesa-libEGL-devel, suggest you check again…

That is correct, you pro file isn’t working, use pkgconfig against egl and pull out the libs.

It builds when using my modified .pro file.
It’s the cmake file that has the problem.
Thanks for the link. :-]