How can I install/use i810 driver instead of intel?


Does anyone know how to use the i810 driver instead of the “intel” driver?

The reason I ask, is because the “intel” driver for me, is absolutely horrible. I use an integrated intel graphics card. I’ve tried numerous xorg tweaks, turning off composite, etc…and I’ve had little luck. There are small speed-ups, but still nothing compared to the i810 driver.

I reinstalled slackware 12.2 the other day, and it apparently has the i810 driver available still. I’ve been using it…and everything is perfect. No strange glitches…no slowness…none of it.

I know it’s not common for people to use the i810 driver anymore, but is it possible to use it with opensuse? If so how?


No promises here. I would backup existing working xorg.conf first with something like

cp /etc/X11/xorg.conf /etc/X11/xorg.working

The following commands require root privileges. Change to runlevel 3 with

init 3

Then try the i810 driver with

sax2 -r -m 0=i810

You can do

man i810

for more info concerning this driver.

If it all goes pear shaped, you can always get a basic working desktop (via failsafe mode) with vesa driver:

sax2 -r -m 0=vesa

I’ve tried that previously with no luck…it claims there is no module i810. However, I got it working with kubuntu. I had to downgrade xorg to the gutsy version, install the i810 driver from there, and lock all the xorg packages. Not a great fix…but it worked. I think I can probably do the same on suse…find an earlier version that had i810, downgrade xorg and install the driver.

I prefer suse over most distros, so i’ll have to try it.

I plan on getting an nvidia card in the near future…but for now I need to use this driver, because the “intel” one is so unbareably slow for me.

Thanks for the help :slight_smile: