How can I force cairo-dock to start on the second monitor

I am using openSUSE 12.1/KDE 4.8.1 on two monitors
First screen (monitor) is viewsonic lcd connected via DVI
Second screen (monitor) samsung tv connected via HDMI
My graphic card is nvidia GeForce GT 220

In the first screen I want to use the plasma-desktop
panel and on the second screen I want to just use the cairo-dock
I have no idea how to make cairo-dock to appear in the
second screen at startup. This is the first time I am using
cairo-dock. Help will be very much appreciated.

Thanks in advance.

Looks like there is no way to force cairo-dock to start on the second screen
unless I change the monitor config. to xinerama. The only option in the cairo-dock
config is for xinerama to make it appear in the other monitor. I am using two separate
screen and don’t feel using xinerama. Any ideas?

I searched and found a solution somewhere.
In the kde startup and shutdown the command to force
it to show on the second screen when kde starts is

DISPLAY=:0.1 cairo-dock

The command works nicely in kde but it doesn’t
work in xfce, hopefully I will be able to find a way to
make it work in xfce also.

I am posting this for reference.
If you want to start cairo-dock on the second screen
when you are using two separate monitors in Xfce

sh -c "sleep 15 && DISPLAY=:0.1 cairo-dock &"

I need to put at least a 15 seconds delay to properly start it on the
second screen.