How can I change the default WindowManager?

Hi, I’ve installed opensuse without graphical interface and added gnome desktop later. The gnome desktop doesn’t start and returns to console. I tried to repair the installation with the suse CD but then it enters automatically to FMWM2 window manager and there is no option for changing it to gnome. How can I change it to gnome?

try YaST- system- etc/sysconfig Editor click on desktop then display manager & set the default there


thank you very much

I suppose gnome3 developers put something on this option, cause it does not change default WM. Can’t change fallback mode’s metacity to xfwm4