host names cannot be resolved except for ping

Hi folks,

I’m running openSUSE 11.2 (Linux piura #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux) and have a network problem. At work, ethernet works fine. When I plug it into my DSL router at home (which works with other computers), I encounter the following behavior: ping can resolve host names, however, traceroute and Firefox and Thunderbird cannot.
It happens for both wired and wireless connections.
Any clue what could be the issue and where I should start searching?


More info: I think I can rule out a router firewall problem because the ipod touch works out of the box with wlan.

No DNS, that’s what causing it. Enter Google’s DNS servers in the networksettings: and

Good luck

If there is no DNS, then why is ping able to resolve host names? I’m puzzled, but I’ll give it a try with the DNS servers you mentioned. Thanks.

Check IPv6 (= turn off) and maybe MTU.

Use host or nslookup to check if your system resolves and what. As ping and all others on the system use tthe same resolver we are very baffled by the fact that ping does what the others don’t.

Can you prove what you say by e.g. showing (that means cutting/pasting and putting between CODE tags) where ping resolves and another (ftrp, ssh …) doesn’t? Like

henk@boven:~> host has address mail is handled by 1 mail is handled by 1
henk@boven:~> ping -c 1
PING ( 56(84) bytes of data.

--- ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms

henk@boven:~> telnet 80
telnet: Name or service not known

(of course the above last telnet command is faked by me, because I do not have your problem)

Sorry about the delay, it took me a while to figure out how to post from my machine with the network problem…
Your last post is exactly how it looks like: host and ping do resolve the name, whereas telnet, traceroute and ssh don’t.

chris@piura:~$ host has address mail is handled by 1 mail is handled by 1
chris@piura:~$ ping -c 1         
PING ( 56(84) bytes of data.

--- ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms

chris@piura:~$ telnet 80
telnet: Name or service not known
chris@piura:~$ /usr/sbin/traceroute Name or service not known         
chris@piura:~$ ssh            
ssh: Could not resolve hostname Name or service not known

Interestingly enough, Knurpht was right and adding google’s DNS servers indeed solves the problem. So, the issue is resolved, thanks. But I am still puzzled about this strange behavior that DNS resolution worked for some programs, while it didn’t for others…

Thanks for the testing and posting.

I am with you: nice that it is solved, but I do not understand it either.

Can you shed light on this Knurpth? Why does a ‘normal’ DNS server resolve (well, that is normal), but what is doing the yes/no tactic on his default (which one) DNS server?


I’m having a similar issue and after many, many google searches and lots of trial and error, I need help.

We have two local networks, A and B on two different subnets, connected via a VPN (through a cisco router). I have two machines on network A called A1 and A2 and one machine on network B, called B1. All three machines are running OpenSuse 11.2. All of the machines have the firewall turned off.

From machine A1, I can ssh, ping, ftp, telnet and traceroute to machine B1.

From machine A2, I can ping B1 but if I try to ssh, ftp, telnet or traceroute I immediately get “connection refused”.

A1 and A2 are able to connect to each other (they’re on the same network) without a problem.

I have set up the routing table on A2 to be identical to that on A1, but still no luck.

I did a tcpdump on machine B1 and requests from A2 don’t appear to even be arriving at B1 so they’re getting blocked somewhere along the way (but router firewall doesn’t explain the issue since A1 can get through).

Any thoughts?


  1. “Connection refused” generally means that you have a firewalling problem (function believed it should work but was actively denied). This would especially be true if the response came back very quickly. Could your router be descriminating between hosts in your A network, for instance IP tables are setup to forward by specific IP addresses and not network ranges?

  2. OP (checkfrogger), that’s an odd problem. It might also have been interesting to repeat the HOST command after the failures to see if something had actually happened to the resolver cache.


See my thread no internet access. I had the same issue. all settings were set to auto DHCP. I was connected to my router and all seemed good ,I could ping sites but could not get anywere on firefox etc…entered and and It was fixed. I’m still puzzeled why I have never had to do that for windows or Ubuntu on the same computer and Network.

Thanks for your quick reply - I’m not having any DNS issues (if you were responding to me). I can go to all websites in the browser and can also ping external hosts by name (e.g. The machine is able to resolve hosts and has full internet access. In fact it can even get to machine “B2” using its external IP address but not using the internal IP address.

Thanks Tony, that’s what I figured but was stumped by the fact that my second machine (with almost identical configuration) can get through. I even tried a static IP address in case that particular IP was being denied. I’ll poke around some more though and see if I find anything. Thank you again for your quick response.

That’s one way to troubleshoot,
Take the machine that works offline and configure the machine that has a problem to use that working IP address. If it works, it’s more evidence (although probably still not conclusive) that your problem is that only that address can forward.