Home sub directories theme missing

I have made a few mistakes and I ended up loosing my /home/user sub directories folder theme such as Downloads, Documents, Videos etc.
Now they are plane folders instead of having the theme icon.
For example, the theme icon of the Downloads folder is an arrow pointing down. Documents is a little paper, and so on.

I have tried to make a new user and send all the data over there, but for some reason the new user do not generate the subdirectories.

I also had tried instructions from this site:

I tried to generate new user by:
sudo useradd -m username
But it did not generate the subdirectories for the new user

Can anyone give me an idea?

Using opensuse 15.2


As far as I know, those subdirectories are created when that new user first logs into a desktop environment.

You don’t have to make a new user to make directories in your home though. Those folders are created empty anyway. Not sure why you want to go to all that trouble to just make a directory.


In Nautilus, just right click on the folder, scroll down to properties and then click on the icon and browse to /usr/share/icons/hicolor/scaleable/places and find your icon of choice (eg folder-music.svg), or if it’s a theme and has icons in ~/.icons then it would be there.

the directories are created on first login.

I know I could change it manually, but in case I change color theme, the folders I change manually I have to change manually again.

It happened because I moved the directories around, so they mysteriously lost the theme.

Thanks again

Have you selected a different theme and back to your one?

Reset the icon theme;

gsettings get org.gnome.desktop.interface icon-theme

gsettings reset org.gnome.desktop.interface icon-theme
gsettings set org.gnome.desktop.interface icon-theme "some-icon-theme"

I had acidentally deleted Documents.
Than I was able only to ‘mkdir’ a folder without, but then it makes a plane folder.
On the attempt to follow som instructions I moved the intirehome folder to another place to avoid to mess up. What happened is that all the other folders became plane folders as soon as I mooved them.

But now I know what to do.


So all good now?

And restoring from the backups did not work?

It’s not the files, is the folder icon… I use softlinks for mine and always have to change manually…


Yes it is all good now.
Thanks for all the help.

I really do not know exactly how it got fixed.
The only thing I really know I did well was the creation of new user (user b) and log in into this user.
Mysteriously the (user a) - the one with the issue, got fixed.
Now I removed the (user b).
I know there must be a proper way to do it. But it is fixed.