home.mount failed

Hello everyone,

I am using openSUSE Tumbleweed. I use for it my work and casual stuff so I always keep it up-to-date.

This morning as always I boot it and start to listening music while checking my emails on Mozilla Firefox. Suddenly system stopped responding while still playing the music. I waited for a couple of minutes but then I had to “Ctrl+Alt Del” then choosed reboot. But it caused the system being lock totally, I mean it was not responding event “Ctrl+Alt F1, F2, etc.”. So I had to hard restart it. After this, everything start to going bad :(.

On the first login attempt, It hanged out on the loading screen of the Tumbleweed. So I hard restart it again. After this on the login it dropped to emergency mode… So I check systemctl --failed. Here is the output,

UNIT LOAD ACTIVE SUB DESCRIPTION
home.mount loaded failed failed /home
auditd.service loaded failed failed Security Auditing Service

and last lines of the systemctl status,

home.mount - /home
Loaded: loaded (/etc/fstab)
Active: failed (Result: signal) since Wed 2016-07-06 13:05:36 EEST; 14min ago
Where: /home
What: /dev/disk/by-uuid/40d29…
Process: 693 ExecMount=/bin/mount -n -t xfs -o defaults /dev/disk/by-uuid/40d29… /home (code=killed, signal=KILL)

Jul 06 13:05:36 linux-tmzz systemd[1]: home.mount mount process exited, code=killed status=9
Jul 06 13:05:36 linux-tmzz systemd[1]: Failed to mount /home.
Jul 06 13:05:36 linux-tmzz systemd[1]: Unit home.mount entered failed state

I have checked man page for mount but there is no any description for return code 9. So all my knowledge ends here :S. I would be very much happy if someone can help me to rescue my system.

By the way, here is the fdisk -l output,

Disk /dev/sda: 232.9 GiB 250059350016 bytes, 488397168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x6a0a3dfc

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 1026047 1024000 500M 7 HPFS/NTFS/exFat
/dev/sda2 1026048 488394751 487368704 232.4G 7 HPFS/NTFS/exFAT

Disk /dev/sdb: 223.6 GiB, 240057409536 bytes, 46862128 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0005da7e

Device Boot Start End Sectors Size Id Type
/dev/sdb1 2048 4208639 4206592 2G 82 Linux swap / Solaris
/dev/sdb2 * 4208640 213921791 209713152 100G 83 Linux
/dev/sdb3 213921792 468860927 254939136 121G 83 Linux

and lsblk output for sdb,

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sdb 8:16 0 223.6G 0 disk
sdb1 8:17 0 2G 0 part [SWAP]
sdb2 8:18 0 100G 0 part /usr/local
sdb3 8:19 0 121.6G 0 part

Being in emergency mode, did you try to mount it “manualy”?

Did you try an fsck on the file system from emergency mode?

When all this fails, such a sudden failure in the midst of working looks to me like a hardware problem. Thus checking the disk might be an option.

mount took too long and was killed by systemd. Normal timeout for service start or execution is 90 seconds. If mount took more than this time, something is wrong with filesystem. As suggested, first try to mount it manually and see whether it works.

I am sorry to late reply.

Yes forgot to mention, I have tried to mount it manually but mount did not return for 5-10mins. But I am not sure what is the wait time before deciding mount failed.

And also after I got your reply, I tried xfs_repair for /dev/sdb3 but did not return as well for 5-10mins.

I have confused totally :S

Thanks for reply.

This is not normal and suggests hardware issue with hard disk. Error recovery may sometimes take exceedingly long time. Post dmesg output after boot stopped in emergency mode (upload to http://susepaste.org).

I am novice :S can you please help me how can I direct dmesg output to susepaste?