Hitman 3 fps cap steam

so i have a laptop with a 300hz refresh rate ide like to limit or cap the fps in hitman 3 because my cpu dose not need to run as hard as it can its stupid and a waste of energy as well. the game i can use v-sync to limit it to my refresh rate but thats 300hz it never reaches that and like i said is a waste of energy and makes my system hot. ive tried turning the v-sync on and off i tried using the v-sync in game limit thing to limit it to half my refresh rate but it dose not work i tried using DXVK_FRAME_RATE=60 %command% as a steam launch option and that dose not work. BUT u can confirm that steam command dose in fact work in every other game the only way i can force 60 fps is to put my monitor in 60hz mode bu its way too much of a hasle to have to remember to turn it to 60 ad back to 300 before and after every time i want to play this ONE game its dumb anyone got any other solutions thanks?

Did you try +fps_max60 in launch options?


yea that one wont let any of my games launch at all so no dice.

That is because you applied the launch option in the wronǵ way. You are not allowed to add “+fps_max60 %command%” or the games wont start anymore. Just add “+fps_max60” as already written and nothing else…
The %command& option is not neaded in the launch options. There is enough documentation what it does and what not…

ok thanks also just tried it like u said and well it launches but its still using whatever fps it wants

If your game settings have no option for limiting the fps, there is not much left what you can do. There are some third party (MS Windows) tools to limit the fps…

ok then thanks is there a way to force the game to change my screens refresh rate before launch and then back on quit automatically?? if not that ten i suppose i have to just deal

so i was playing koikatsu and noticed that these steam commands also dont seem to be working on koikatsu im assuming since both those games gave a launcher it wont work with launchers not unless there is a way to apply them after the launcher.

Other possible options could be libstrangle or gamescope. As far as I know neither of those have a package in the repository.

so i have confirmed that for example with koikatsu party if i run the game normally it launches a launcher then the steam commands wont work BUT if i add a new game to my steam library and browse for he koikatsu exe it skips the launcher and the steam commands work just fine. so how would i go about skiping a launcher with steam cimmands or fixing this should i open a bug report?

The “+fps_max60” is only for games with source engine as written on the page linked above.
If you want to set a fps cap for Hitman 3 you have to do this in the game settings of Hitman 3.

Search for Hitman 3 and fps cap on the internet and you get: V-Sync Interval and V-Sync to enable a fps cap in Hitman 3.

This not an openSUSE nor a Steam problem.