Help with setting permissions for usb device by udev

I’ve been trying to set permissions for an usb-device by udev. However, I can set the GROUP and/or OWNER correctly, but MODE seems to have no effect. This is the rule I’ve been using:

SUBSYSTEM=="usb", ATTR{manufacturer}=="Suunto", ATTR{idVendor}=="0403", ATTR{idProduct}=="f680", GROUP="kvm", MODE="0664"

This results in:

blackbox:/etc/udev/rules.d # ls -al /dev/bus/usb/001
total 0
drwxr-xr-x 2 root root      80 Feb 19 01:07 .
drwxr-xr-x 7 root root     140 Feb 18 15:58 ..
crw-r--r-- 1 root root 189,  0 Feb 18 15:58 001
crw-r--r-- 1 root kvm  189, 17 Feb 19 01:07 018

So the group is correct but the permissions aren’t. Does anyone know that is there something wrong in the udev rule or am I missing something else?

You can only set the permissions on a USB device if it has a Linux file format. Otherwise, you are restricted to changing the permissions globally. However, as I assume you won’t want the same restricted permissions for every USB device, that is probably inadvisable.

Ah, ok. Well, setting myself as OWNER suffices so, I’ll just work with that. Thanks!