Help with Apache Reverse Proxy vhost

I have looked everywhere and have tried plenty but cannot get this right. PLEASE HELP!

  • I have a dotnet core2 kestral api application that listens on localhost:5000
  • I allow people to use api via apache on serverIP:17169
  • Im using SLES 12 with latest updates etc.

I have this setup on CentOS, and it was easy - VERY easy.

I had all the reverse proxy info in the vhost.conf and it all worked:
config was

<VirtualHost *:17169>
    ProxyPreserveHost On
    ProxyPass /
    ProxyPassReverse /
    DocumentRoot "/path/to/doc/root"
    ServerName "server1"
    ServerAlias "server1"

I understand that SUSE does things differently, where it splits up most things into .conf.
I have enabled mod_proxy but when I run
httpd -M
I dont see the module listed

Please can someone walk me through how I would set this up. My current vhost definition is

<VirtualHost *:17169>
    DocumentRoot "{{ document_root }}/{{ website_2 }}"
    ServerName "{{ website_2 }}"
    ServerAlias "{{ website_2 }}"
    <IfModule mod_proxy.c>
    ProxyPass /
    ProxyPassReverse /
    ErrorLog /var/log/apache2/{{ website_2 }}/error_log
    CustomLog /var/log/apache2/{{ website_2 }}/access_log vhost_combined
    <Directory "/path/to/doc/root">
    Require all granted

I have another :80 vhost website on the same server and its working.

httpd -t says my syntax is OK

I get the just of the differences with apache2 on SUSE but cannot get this right…

Please please help

The SLES forums are at

Only openSUSE are discussed here because of differences.


No worries, thanks for the update.

I figured it out with much swearing and coffee :slight_smile: