Help, Trying to upgrade from 12.3

Thank you tau, I thought so. But in my ignorance I backed up etc/fstab, then edited it and changed the uuid of home to be the correct one.
Tried a reboot and it stopped. No problem says I just remove the edited fstab and replace it with the fstab-bak file and reboot.
Alas, I cannot boot at all. It always hangs with a big gear and a K
I think I will give up

Always weigh grabbing any important file and rebuilding vs fixing the problem.
Try removing the KDE settings (the hidden KDE files in your /home), then try rebooting again.
It sounds like your boot has progressed to the point it’s trying to load KDE but maybe something in your KDE config is causing the problem. Removing those KDE hidden files removes your personal preference settings, but allows KDE to re-create the way it likes it.


I don’t know how to get there. Every login option hangs up.
Is there a hot key that I can press to interrupt the boot sequence ?

Ok removed. Kde4 and rebooted. It got further, in that I see the full gear K thing, and the cursor disappeared but I think it is still hung.
How long do I wait until I try the advanced boot ?
2 minutes.
Tried option 2 advanced, then option 1 still hangs
Option 2 advanced, option 2 got me to a login. When I login it hangs again with the gear. But the cursor moves. Ctl esc shows activity but then hangs
I’m stuck

At the login screen I tried logging in as root, it did but hangged.

Got to a login, tried as root and it took then hung.
Gonna try another full install

Ok, new install and i am back to a good desktop and thats it for today.
I’ll try to find home tomorrow.

FYI When you select “Advanced” in the GRUB menu,
Kernels are listed in pairs,
The first time a kernel is listed, it’s the normal boot kernel, so the very top entry is no different than a default “normal” boot so you’ll see the same problems as a default normal boot.
The second line is the emergency boot for that kernel.

Then, if you have multiple kernels, the next pair is your next older kernel and like the first pair the first line is the normal boot and the second line is the emergency boot using that kernel.

I’ve asked the maintainers to display the entire lines, but so far the decision is to display only the chopped off lines.

I wrote an easy to install fix for past openSUSE versions and may write another fix for 42.3, but of course the typical User won’t have my fix installed before needing to see those Advanced kernel entries the first time needed.


Can’t they at least abbreviate?
And thanks again. Now to try and figure out how to find the proper home.

and this is what fdisk shows.

Disk /dev/sdb: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x0006fdc2

Device     Boot      Start        End    Sectors   Size Id Type
/dev/sdb1             2048 1543925759 1543923712 736.2G 83 Linux
/dev/sdb2  *    1543925760 1584885759   40960000  19.5G 83 Linux
/dev/sdb3       1584887806 1953523711  368635906 175.8G  5 Extended
/dev/sdb5       1584887808 1945663487  360775680   172G 83 Linux
/dev/sdb6       1945665536 1953523711    7858176   3.8G 82 Linux swap / Solaris

Partition 3 does not start on physical sector boundary.

Disk /dev/sda: 238.5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x925591c7

Device     Boot    Start       End   Sectors   Size Id Type
/dev/sda1  *        2048  83892223  83890176    40G 83 Linux
/dev/sda2       83892224 500117503 416225280 198.5G 83 Linux

Some reading about changing the location of /home for user fubar causes me to ask more.
Should I do the change as Dunbar or root ?
Could I use usermod ?
How about just unmount and mount ?


How about Yast - partitioner you can change any mount point you want there

Let me see if I can figure it out
Get a warning,
Some subvolumes of root are shadowed by mount points of other filesystems and could lead to problems.

Proceed ?

well I went ahead and now there are other problems.
In partitioner I changed sdb1, ext4 to be /home.

Now when I poke the home button on the desktop I get an error

 p, li { white-space: pre-wrap; }  Unable to run the command specified. The file or folder /home/hexdump/Desktop//Home.desktop does not exist.

sdb1 structure has
hexdump —> my user name
sunhui --------wifes user name
/sdb1/hexdump/—> has all my data folders including my original desktop with all its entries.

so how do I get Leap home icon to point to sdb1 properly ?

And now using yast, I tried to unmount the /home mount point and Leap wont let me, sheesh.
says error code -3002.

and all of a sudden my desktop icons appear !!!
so, back to square 1 to try and associate the icons to the missing apps.

Im getting closer.

Wow, I walk away for lunch and come back to this
The screen locker is broken, unlocking is not possible.
Whoa, is this booger ready ?