Help, Trying to upgrade from 12.3

Doing it from DVD and it went fairly smoothly with I think 3 error messages.

  1. installing boot manager. I am not listing the full message…
    /usr/sbin/grub2-install -target=i386-pc,/dev/sda2,failed
    Exit code 1
    Error output installing for i386-pc-platform

  2. /usr/sbin/grub2-install: error the drive hd0 is defined multiple times in device Mao.

After the upgrade and at the restart I get a lightbulb and “no system tray detected”
Unable to start, exiting and hangs.
When booting I get 5 options.
1 leap 42.3 linux 4.4.76-1-def…off the screen
2 leap 42.3 linux 4.4.76-1-def…off the screen
3-5 leap 43.3 linux different

Selecting 1 gives a bulb, login splash then hangs
Selecting 2 gives me a bulb, login splash and a wrench tool with 9 choices and I tried a few of them.
The most promising was 9, failsafe which got me a command window.
In an attempt to fix the nvidia display issue, I did the same thing that worked last time.
a) sudo zipper ar ftp://download.nvidia.com/opensuse/42.3 nvidia
It installed ok but when I tried the sudo zipper in x11video-nvidiaG02,etc
I got an error "download error, connection failures ".

Any ideas on how I can get this beast back on the air ?

Thanks

How?

Doing a fresh install (while keeping your data in e.g. .home?

Using th Upgrade option in the menu?

I doubt the latter is supported in so big a leap to Leap.

I picked upgrade

Yes using the upgrade option.
Yikes, it’s not supported !!! Tell me it ain’t so

Hmmm, iceWM runs a stripped down app of sons kind. I am gonna poke around and see if I can get the video working properly

Confusion, when I try to run nvidia-config I get the looking for xorg-server.pc in pkg_config-path.
So, reading all about nvidia and xorg there is conflict.
Some say use the community nvidia repository whereas Wolfe says that the G03 or G02 files don’t work.
There appears to be a G04 also.
Can someone point me to the correct steps to get nvidia working ?

My head hurts

a) You don’t need nvidia-config or anything else - it’s all autoconfiguration nowadays.
b) What is your GPU?

Gpu is a nvidia 7050 620i

AFAIK IceWM is an Openbox environment,
It doesn’t support advanced graphics.

You need to have a properly working full Desktop,
It sounds like something broke when after your login page your Desktop failed to load and likely dropped you into IceWM.

Recommend:
Try booting to “Advanced Options” and then select a “Repair” kernel configuration (Most likely each entry will be chopped off, kernels are listed in pairs of Normal Boot/Repair Boot, so select the second of a pair).
If booting to a Repair configuration isn’t helpful, then try using a DVD ISO to repair your system.

What Desktop were you running?

If you need old, unsupported versions of DVD ISOs and last published Update repositories, I posted links to those in the following Forum post
https://forums.opensuse.org/showthread.php/526205-need-opensus-13-2-iso?p=2831820#post2831820

TSU

I was into iceWM manually as it has a lot of options like yast, etc. I was hoping that using some of those tools would make it easier to fix this.
Ok, I tried a re update. There is no repair option. I was running kde
Doing the upgrade again I got another few errors.
1 in the packages said something like this.
Package conflicts kernel default 4.4.76-1.1.x86_64 etc
Keep
Do not install
And I picked keep
2 drm-kmp-default —a bunch of numbers – requires kysm and cannot be provided.
Sheesh.
Anyhow, I proceeded to the end and still hangs.
When I reboot from the DVD and retry the upgrade, there are 6 function keys
1 help
3 video mode
5 kernel default
6 driver no
I selected 3=800×600, 5=safe
Didn’t seem to make any difference.

The 1st boot screen gives me 4 choices.
Suse 42.3
Suse 42.3 advanced…i picked this. And it gave me 5 options
1 linux 4.4.76-1-def
2 ----same----- I assume some advanced stuff – I picked this
3&4 linux 3.16
And a bunch more

A few red and yellow messages flew by and it got to a low quality login screen with the wrench in the lower left.
Wrench choices are
Plasma 5
User/system default
Custom
IceWM previous — thus is how I started iceWM
Kde plasma workspace
Kde plasma workspace failsafe session
Plasma 5
Twm
Failsafe --this gets me to a purple terminal window

So, going back to the beginning would it do any good to try an install rather than an upgrade ?
And will the install respect where home is ?
Also, what command do I enter to see where home resides ?

Thanks

Oops, it’s actually 13.2

I started doing an install but didn’t like where it was mapping stuff.
Plus it wanted to change sdb1 to btrfs which is where home is,I think. Yikes !

Well take control and tell the installer where you want things to go and where to mount. The installer can’t guess what you want it does a best guess

You mean you are trying to update from 132. instead of 12.3 as you said before?
That changes a lot, because AFAIK that is supported using the upgrade option of the DVD.

The DVD should be able to upgrade a 13.2 without unusual steps.
IMO when you upgrade you likely shouldn’t keep anything, accept only new components… but YMMV depending on what is installed in your system.

At some point,
It might be better to do an install instead of upgrade. Done properly, the only things you <will> lose are any non-default applications you’ve installed. You <might> lose your personal settings, but there’s a reasonable chance you can salvage that.

Of course, always backup or copy to external storage anything you feel is valuable, most particularly your /home partition’s contents.

I’ve posted several times the procedure to install new while preserving your personal files and contents (you might want to search my posts for these instructions)

Assumes your root and /home are in separate partitions which has been the default for many openSUSE versions.
Basic idea is to wipe the root partition but retain your /home partition, optionally re-sizing. I recommend using Gparted Live for this.
Then when you boot your install DVD, it will find the free space and offer to install openSUSE into it, but you will want to “Edit…” the layout. By default, the DVD will offer to create a new /home partition in the empty space, but instead you want to install only the swap and root partitions into the empty space, you simply find the dropdown on the page specifying the /home location and point that to your existing partition.

With that simple but critical step (pointing the install to your existing /home partition), you will preserve you personal files and Desktop settings. If you install the same Desktop, it’ll automatically read the settings from your old install into the new install.

HTH,
TSU

Well I did an install after reading a bunch of stuff. I changed a few things but not much.
At reboot, it crashed with this error.
4.756178 ext4-fs can’t find ext4 filesystem
In emergency mode.
One other thing was that there used to be an option to boot into Mint, and after the upgrade it was still there, but it is gone now.
Doing a df and there seem to be a lot missing
I only see sda2 “/” and sdb1 “home”
Where did the others go ?

Pls post what you see instead of just describing highlights, eg

df -H

also, depending on whether your disk is MBR or GPT one of the following will return output

fdisk -l
gdisk -l

TSU

Well after a lot of installs, etc, including Mint, I did 42.3 again and now I am able to boot.
Though home is pointing to the wrong place. So, how can I change home.
Also my desktop is gone and I might not be able to get it back.
This time during the install I told it to use all of sea.
As another poster suggested, I tried to gain control of the partitions, etc. I must say that it is very confusing.
Anyhow, now for the desktop and home.

In my sdc “home”, I also have my old desktop.
How can I make it active ?

Run either “fdisk -l” or gdisk-l" as I suggested to display partitions on your disk.
Identify how your partitions are identified.

Then, run your openSUSE and inspect the fstab.
You should see /home pointing to the newly created partition.
Modify that line to point to your old /home partition identified by the first step above.

Congrats, you’re making progress,
TSU