help resolve zypper dup

I got notice of 200+ updates available for TW. When I ran zypper dup, I got this error message:

Retrieving repository 'Main Repository (NON-OSS)' metadata .......................[done]
Building repository 'Main Repository (NON-OSS)' cache ............................[done]
Retrieving repository 'Main Repository (OSS)' metadata ...........................[done]
Building repository 'Main Repository (OSS)' cache ................................[done]
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
3 Problems:
Problem: yast2-bootloader-4.0.13-1.2.x86_64 requires rubygem(ruby:2.5.0:cfa_grub2) >= 0.
5.1, but this requirement cannot be provided
Problem: ruby2.4-rubygem-ruby-augeas-0.5.0-3.6.x86_64 requires ruby(abi) = 2.4.0, but th
is requirement cannot be provided
Problem: yast2-storage-ng-4.0.70-1.1.noarch requires yast2 >= 4.0.24, but this requireme
nt cannot be provided

Problem: yast2-bootloader-4.0.13-1.2.x86_64 requires rubygem(ruby:2.5.0:cfa_grub2) >= 0.
5.1, but this requirement cannot be provided
  uninstallable providers: ruby2.5-rubygem-cfa_grub2-0.6.5-1.3.i586[download.opensuse.or
 Solution 1: Following actions will be done:
  deinstallation of ruby2.4-2.4.3-2.1.x86_64
  deinstallation of ruby2.4-rubygem-ruby-dbus-0.14.0-1.1.x86_64
 Solution 2: deinstallation of libstorage-ng-ruby-3.3.112-1.1.x86_64
 Solution 3: deinstallation of yast2-bootloader-4.0.13-1.1.x86_64
 Solution 4: keep obsolete yast2-bootloader-4.0.13-1.1.x86_64
 Solution 5: break yast2-bootloader-4.0.13-1.2.x86_64 by ignoring some of its dependenci

The only other “repo” I have is the Tumbleweed install disk. Should I add another repo? If so, which one? I tried adding both packman and Google last week and both failed, even though I did it from links in the forum.

I was thinking I could just wait until the rubygem shows up or keep the obsolete yast2-bootloader.


TW switched to Ruby 2.5 on snapshot 20180124. During upgrade, Ruby 2.4 will be removed and Ruby 2.5 will be installed instead.

When I performed the upgrade, this switch was done automatically. So I am wondering is there anything installed in your system prevents this switch happening automatically.

Have you tried to choose option 1 to see if any further error messages will pop up? Anyway, you can cancel the upgrade even after you choose option 1 and get any new message.

BTW, I think it will help others to diagnose if you give the results of

sudo zypper lr -E --uri

When I read my own post about repos, I realized that I had the dvd enabled but not in the drive. I disabled the dvd “repo” and ran the zypper dup. The error disappeared. I guess the dvd had priority over the online repos. As mentioned above, TW upgraded to Ruby 2.5. Thanks for trying to help me out :slight_smile:

I added the last 3 repos after I resolved the error message by disabling the dvd.

# | Alias                                  | Name                      | Enabled | GPG Check | Refresh | URI                                                   
1 |          | Main Repository (NON-OSS) | Yes     | (r ) Yes  | Yes     |
2 |              | Main Repository (OSS)     | Yes     | (r ) Yes  | Yes     |     
3 |       | Main Update Repository    | Yes     | (r ) Yes  | Yes     |       
4 | google-chrome                          | google-chrome             | Yes     | (r ) Yes  | Yes     |   
6 | | libdvdcss repository      | Yes     | (r ) Yes  | Yes     |                                    
7 |   | Packman Repository        | Yes     | (r ) Yes  | Yes     |                                      
**localhost:~ #**                                 

Besides dvd, I also have source and debug repos. All 3 are not enabled. This all looks good to me. Right?

Option 1
To delete the old Ruby and allow the upgrade

This may not be the case because the dvd repo should have package versions equal or lower than those in online repo so they do not have “priority over the online repos”.

Looks good to me.

This may be the right choice.

But anyway, your problem is gone. I guess we have no basis for further debugging :wink: Have a good day.

This is not necessarily true. TW snapshots are integral only to themselves and are not updates, hence version and especially build numbers do not relate between snapshots. There is also the possibility that retaining an old snapshot (DVD) will interfere with the deletion of obsolete packages.

I guess that possibility does exist given that recently the ucode-intel is changed from 20180108 to 20171117.

Sorry to all for my misleading words.