Help needed to update my nVidia drivers


I’m having a hard time with my nvidia drivers. I’m using the proprietary ones, but I just downloaded Alien:Isolation and the game won’t run because the drivers are outdated :
I’ve been having many issues with my nvidia drivers over the past year and I haven’t changed anything about that after these issues were fixed. I don’t want to mess with them again, so I’m asking for your help. Here is some info about my installation.

Mon Feb  8 22:16:26 2016       
| NVIDIA-SMI 346.59     Driver Version: 346.59         |                       
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce GTX 750     Off  | 0000:01:00.0     N/A |                  N/A |
| 21%   35C    P8    N/A /  N/A |    582MiB /  2047MiB |     N/A      Default |
| Processes:                                                       GPU Memory |
|  GPU       PID  Type  Process name                               Usage      |
|    0            C+G   Not Supported                                         |

Now the problem is I have a ton of nvidia drivers installed and I don’t think they are all needed :

rpm -qa | grep "nvidia"

When I open Yast, I can see that packets like x11-video-nvidiaG03 and x11-video-nvidiaG04 are installed for example. Do I actually need them both (one is for Geforce 400 series and the other is for Geforce 8xxx ones). Many packages can be updated via Yast, but for most of them, there are dependencies issues and I have to uninstall/break something. I’m very confused at the moment, so feel to let me know what other information I can provide. Here are a couple screenshots :

Thank you in advance for your help.

Because openSUSE keeps the last kernel and packages when the kernel gets updated. You can have different versions for the different kernels. I see you have GO3 and GO4 that is unusual but may indicate you switched flavours after a kernel update. 352.79 is the latest official Linux driver so if you really need 355,11 then you may need to look for a beta and install the hard way

I can see that the version I have is 346.59. Can you please elaborate a bit more about the procedure? For now, I really don’t know what package to update. Thanks

So the one thing I was afraid of happened. I ran an update of the x11-video-nvidiaG03 package and now I get an “Oh Snap” message when I log in. Here is a sample of the /var/log/messages file.


I don’t think I can be more clear 355+ does not yet exist in the Linux world except as a beta from NVIDIA. You can not get it via Yast or zypper you must download from NVIDIA and install the hard way.

It is not at all clear what you did or in what state the machine is now. If me I’d remove all NVIDA packages and start over. If you must have 355+ version you must get it from NVIDIA

Then how can I get the latest version available? The version I had running was not 352.79 but something even older, which is why I wanted to make an update. Since I have to reinstall all the nvidia packages, can you list the ones I actually need? Thanks

NEVER! install several driver versions (e.g. G03 and G04) at the same time!
They contain the same files and overwrite each other.

Even if you are lucky and it works at first, it will definitely break after a driver update.

So, remove all nvidia packages and then install the one you want again:

sudo zypper rm *nvidia*
sudo zypper in x11-video-nvidiaG04

Or, if you prefer G03, replace the last line with:

sudo zypper in x11-video-nvidiaG03

Actually instead of installing the driver explicitly, you should also be able to just run “zypper inr” (INstall Recommends) and zypper should pick the correct version, or just open YaST (the driver should be pre-selected).
This is actually the preferred way, as YaST or zypper might want to automatically install another version otherwise.

See also: SDB:NVIDIA drivers - openSUSE Wiki

Thank you. I found this solution a couple hours ago and it worked fine. I used G04 though.