Help needed: How to use DVD-ISO as repository

With the help of “Installation without CD” on this site I’ve been able to add the linux and initrd from 11.1 to my existing 10.2 system and also to edit the GRUB menu so that the 11.1 kernel starts and the install routine begins.

But when the install starts to look for the repository it says there’s none when I point it to the 4.3GB ISO file. As of now I didn’t find a solution. As a matter of fact I couldn’t even identify the problem since the manual above says exact that, just with a CD ISO name instead of a DVD one.

Does it matter which filesystem the ISO file is on? I guess not much since the single ISO file is read only anyway. It’s now on NTFS.

In the meantime I had extracted the ISO content with Daemon Tools, pointing GRUB to linux&initrd on there which didn’t work. I assume that’s because of the NTFS filesystem the kernel probably can read only. Then again, even I would reformat that partition to FAT32 - had to convert to NTFS because of the 4GB size limit - and then unpack the ISO-DVD thereto where would I point the install routine to to not get only a “Repository not found” reply?

You probably need to load the ntfs-3g module for linux to read it.
You can also just copy the iso file as is to an ext3 partition.

Since I want to install from DVD-ISO I don’t know at all if it’s possible to load that module even before the install routine begins. I mean, the linux&initrd-files I could place into the existing 10.2 system but still I’d be clueless how to tell that new 11.1 kernel to load that ntfs-module.

Anyway, I’d prefer the second way. I can easily wipe that small data partition and make it ext3, no problem. So then I will put either the single ISO-file or its unpacked content to that ext3-partition. Will the partition being ext3 make the 11.1 kernel and its install routine consider either one to be a repository it can install from? Or what entry point do I have to tell the install routine to start the install at?

Thanks already. I’m confident I will get this not-so-regular problem solved sooner or later. = : - )

Here is how I’ve upgraded to 11.0 (and how I’m about to update to 11.1):

I’ve copied the DVD content to a dedicated partition (ext3) on a separated hard disk (for safety).
Here, it’s on the third partition of the first disk, so the entry in /boot/grub/menu.lst looks like:


title openSUSE 11.1 - Install disk
    kernel (hd0,2)/boot/i386/loader/linux splash=silent showopts
    initrd (hd0,2)/boot/i386/loader/initrd

(Remember Grub start to count from 0.)

For the installation:

  • Select ‘Install from HD’.
  • Choose the partition the DVD content was copied to. Note it will not show as (hdx,x) - here it is /dev/sdc3 -. Check your /boot/grub/device.map to find the right disk if in doubt.
  • Enter / as directory (or the directory where you have copied the DVD).

The installer should properly set the install source as a repository; but if not, you can set it later from Yast.

Thank you very much! = : - )

It now worked and I’m typing this now from my new 11.1 system, a first time WLAN connect from a Linux due to the now good WLAN support, even for this not so old Netgear WG111v3. Happy me.

It could’ve worked beforehand even, probably from the beginning on with just the single 4.3GB ISO file. What I had understood wrong during the install routine were the two input boxes after chosing “Install from HD”. While I was right with naming the ISO file or the unarchived content location at the second input request I had falsy considered the first partitions checkbox to aim the partition the new installation should go to. Thanks to your comment I now finally understood that it’s for chosing the install files are coming from.

So I guess both, packed and unpacked ISO file could’ve worked from the beginning on, as well as any filesystem, be it ntfs, fat32 or ext3 as installation source.

Thanks again, worked like a charm now! = : - )

Glad to have helped.

I find it fair to try to help other users, especially when you have yourself received help from other users.
(Isn’t it what we call a community ? :wink: )