Help!! My localhost isn't working.

Help!! My localhost isn’t working. I just switched to OpenSUSE 11.0. This is my first redhat based distro, so some things are a little bit different. I was using Ubuntu before that, but I couldn’t get it to install on my new (used) laptop, so I switched. All I’ve really done is install software so far; some games for fun, mysql, php, apache, and some mysql tools. Localhost should work, but it doesn’t. Rather than hack through this situation, possibly breaking things in the process, I thought I would just ask, and hopefully save myself some headaches. I trying to set up a lamp server for development purposes. In Ubuntu, all I had to do was install the software, and it worked. Is it supposed to be the same in OpenSUSE? Have I missed something? Have I messed something up? Should I uninstal and then reinstall my Lamp software? This is what I get when I browse to localhost.

Failed to Connect
Firefox can't establish a connection to the server at localhost.

Though the site seems valid, the browser was unable to establish a connection.

    * Could the site be temporarily unavailable? Try again later.
    * Are you unable to browse other sites?  Check the computer's network connection.
    * Is your computer or network protected by a firewall or proxy? Incorrect settings can interfere with Web browsing.

So, any ideas? I haven’t done anything with my firewall; could that be it? I would like to get back to work on my project as soon as possible, before I forget what I was doing. Any help on this matter would be greatly appreciated.

tried the same with my 11.0 install got the same results, I assume
you are trying to connect to apache? You need to have a server
setup to connect to. For instance i can connect to the cups
that is installed which i believe is a “server”. If it was an
http connect with ubuntu I would assume that it sets up a http
server by default…dont know for sure as I have only run
Opensuse and Redhat. If it is a standalone machine I would
disable the firewall also. If apache is installed the apache
setup would be the place to look…just thoughts as if you
are a developer you would certainly know more than I. I have
trouble writing simple c scripts


You need to make sure that apache is started and running.

From a command line:

rcapache2 status

to check the status :wink:

rcapache2 restart to stop and start.

You do not need to worry about the firewall to talk to localhost.

Of course make sure apache is installed first.

from command line:
rpm -qa | grep apache

If nothing is returned then apache is not installed.

To quickly install, from a command line: as root equiv

yast -i apache2


Thank you so much. The server just wasn’t started. It was with Ubuntu, but I think it makes more sense to not start it by default. Now I’ve just got a few directory permission issues to sort through, but that should be easy enough. Thanks again.