[HELP] error: unable to find 'cc' in your path

when i in the middle of installing nvidia driver i got this error message,
unable to find the development tool ‘cc’ in your path. please make sure you have the package ‘gcc’ installed. if gcc installed on your system, please check ‘cc’ is in your path

how to check i had gcc installed? and if i dont, how to install it?

thanks for helping

Use zypper… do you have the kernel-source, make etc installed, if
not add them to the list?

sudo zypper in make gcc43 kernel-source kernel-syms

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 16:34, 2 users, load average: 0.03, 0.32, 0.25
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

You go into YaST/Software/Install and Remove Software and type gcc into the Search box. Then you tick the gcc package (nothing else!) and click Accept.:slight_smile:
Good luck!

im using this OS just for several days ago… this new interface is really cofusing me…
and 1 more thing… i want to use kate…
after searching i download this, kdbase-3.5.9.tr.bz2 and now i have no idea how to install it to my computer. btw is it the correct aplication for kate?

i’ve ran that code and then been replied by some freak language i dont understand…

what is that?

Weird, your using a mirror that is greek, russian???

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 17:30, 2 users, load average: 0.18, 0.13, 0.05
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

i have no idea what that is and where that language come from… what do i have to do now? how to change it to english?

how to go to YaST/Software/Install ?
sorry for the stupid wuestion:(
newbie suffering:(

Yeah, that’s Russian alright. It’s essentially asking you to confirm the installation of the selected packages which will take 282 MB of your drive. I suggest you do all that from YaST, it’s far more newbie-friendly (or, as they say, “mouse-driven”).
Ditto for Kate; the package you’re trying to install is NOT Kate - its the fundamental KDE package. If you already have KDE (and even if you don’t), the route to go is:
YaST (you can even run “yast” from a console if you like - but first type su to get root)
Install/Remove Software
Search: Kate
Tick the desired package (you’ll recognize it, it’s named — Kate!)
Click Accept.
If you don’t have KDE yet, YaST will ask you to install it. Just click Accept.

Believe it or not, there are little things in liGNUx that can be accomplished without compiling a new kernel or writing a new x-windows system from scratch.

Oh, and by the way: installing obscure packages in languages you don’t understand and you don’t even know where they came from (!!!) is a fool-proof way to screw up your system in no time. Yes, liGNUx is robust – but not that robust.

sorry wrong post

hi guys, btw how to change this weird language to english?

hai i already tried that but i still cannot install my vga driver… the error message is still the same

problem solved…:smiley: i installed gcc from yast… thx all from the very usefull help:D

Did the linux-kernel-headers install?

This is my canned response for doing it the ‘Hard Way’ :slight_smile:

You can download the driver for your arch from;
Nvidia Unix Drivers

On the download page, check that your card is supported by the driver
your about to download by using the following command;

/sbin/lspci -nv |grep VGA |cut -f4 -d ":"

From the above output use the four numbers from the output to look
at the Supported Products List (on the left) to verify your card is
supported by the driver.

You may wish to ensure your system is up to date. The first command
refreshes the repositories, the second lists any updates, the third
will apply the updates.

sudo zypper ref
sudo zypper lu
sudo zypper up

If you don’t have the kernel source and tools etc installed then

sudo zypper in kernel-source linux-kernel-headers kernel-syms
sudo zypper in -t pattern devel_basis devel_C_C++

Press ctrl+alt+F1 and login as your user :slight_smile:

su -
init 3

cd to the Nvidia Unix Driver you downloaded

sh NV*.run -q
sax2 -r -m 0=nvidia
init 5 && exit

The ctrl+alt+F7 gets you back to the GUI (X session).

Now after a kernel update, you don’t need to run the sax2 command, just
the others to get to run level 3, rebuild the driver and exit.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 13:34, 1 user, load average: 0.02, 0.06, 0.14
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

yep i alrady do it and all working now… thx man… btw do you now how to change that weird laguege to english?