Help! Can't open yast.

I am running openSuse 13.2 KDE. After setting files to paranoid yast2 doesn’t accept my password. Why?

Very bad idea.

“paranoid” means that no user can gain root privileges at all any more, neither via su, sudo, or the desktop equivalents (kdesu, gnomesu, xdg-su).

Login as root (maybe in text mode) and revert your change to “fix” that.

I didn’t know that. How do I login as root (maybe in text mode) and revert your change to “fix” that?

Well, what do you think why it’s called “paranoid”? :wink:
It’s definitely not intended for “normal” usage.

How do I login as root (maybe in text mode) and revert your change to “fix” that?

Press Ctrl+Alt+F1 to switch to text mode.
Then enter “root” as username and the root password as password.

When logged in successfully, run “yast” and change back the setting where you changed it to “paranoid” in the first place.
Alternatively you can open /etc/sysconfig/security in a text editor, set PERMISSION_SECURITY=“easy local” (modify the existing line), and run “chkstat --system” afterwards to apply the change.

Thanks. I am actually paranoid. :wink: I actually did a re-install. The one thing they need to correct is the automatic check save password which is the reason why I messed with it. Once again I didn’t watch for the check. Now yast opens without a password again. >:( I came from Windows and started using openSuse 13.2 since yesterday. Lots to learn. :\ How I fix that so I need a password?

There’s no need to.
It only remembers the password for 5 minutes.

If you are using KDE, you can disable that “Remember password” checkbox by default:
Open the file ~/.kde4/share/config/kdesurc in a text editor, and add the following:


(if similar lines already exist, just modify them accordingly)

To achieve the same, you can also type this into a terminal window (Konsole e.g.):

kwriteconfig --file kdesurc --group Passwords --key Keep false

I am using KDE but there is no such file in the tex editor. I tried the terminal and it didn’t work. :frowning: I guess I will have to live with it like that.

You should create such a file with a text editor, if it doesn’t exist.

But note that .kde4 is a hidden directory. So you have to enable “Show hidden directories” in your file manager or the text editor’s file dialog first.
Or run this:

kwrite ~/.kde4/share/config/kdesurc

If there’s text in the window, modify it accordingly. If the window is empty, enter (or copy/paste) exactly what I posted in my previous reply.
Then save your changes.

I tried the terminal and it didn’t work. :frowning:

It does work.
But you have to run it as user, not root. So I hope you didn’t use a “Terminal - Super User Mode”…

And just to be sure: this only makes the checkbox unticked by default.
It doesn’t make the password dialog reappear if the password is still remembered. But it will be forgotten after 5 minutes (or logout/login) anyway.

note the period in front of .kde4 it indicates a hidden file or directory

Easiest way for someone that has command line fear is to open the Dolphin file browser go to view and check show hidden files navigate to the above file and right click and select open with and select a text editor

There is no reason to just leave it not working as you would like.

I don’t really recommend you use paranoid setting until you understand what they do. If in the process of trying to lock things down again you manage to get in the same situation you can boot to a terminal and log in as root. Form there you can run the command line version of yast and undo what ever you did. To boot to terminal at the grub boot screen press e this will bring up edit mode. find the line that starts linux= go to the complete end of the line (it wraps) enter a space and a 3 press F10 to continues boot this will start things in terminal mode or run level 3 in Linux speak. You will then get a log in prompt (in text) and enter root then enter the root password when prompted. Type yast to start yast

Excellent! It works now. :slight_smile: Thank you very much.