HEADS-UP: Please upgrade Tumbleweed to 20240311 via zypper dup in a TTY

TW snapshot 20240311 includes a major upgrade to Plasma 6.
To avoid a broken system due to an incomplete upgrade, make sure to use “zypper dup” in a TTY terminal (CTRL+ALT+F4 or similar) and NOT start it from within a Graphical Desktop session.
Or use a screen or tmux session (but you don’t need my advice if you are using those :wink: )


To add to this, it’s also possible to perform dup without affecting currently running system by using transactional-update (TU):

Disclaimer: This is not recommended by existing members of the forum, but I’ve found it works for me on Tumbleweed and Slowroll.

Now I have done this upgrade from a graphical desktop, and have indeed many problems. One is that my editor Kile does not start anymore, it asks for an okular library, although okular is installed. What should I do now?

1 Like

Revert back to a previous snapshot, then do sudo zypper dup -d if you want to download the update first, install later, then switch to a TTY or iceWM and run the full system upgrade.

If you still have network connectivity, just CTRL+ALT+F4, login as root and give “zypper dup” another chance to complete the upgrade (you should already find the needed packages in the cache, no need to download more). With no network, you may try:

zypper --no-refresh dup
1 Like

Hi OrsoBruno, hi Basilcat,

Thank you both! I still have network connectivity. But I have Ext4 as a file system, and I do not have snapper installed. So I think that I cannot revert back to a previous snapshop, is that correct? Shall I still try to run the command “zypper dup” from a terminal?

1 Like

First off, thanks much for the suggestions on how to complete the upgrade process. My situation was that running the upgrade from my normal Plasma desktop terminated at some point and left me at the KDE login screen. Logging in failed to load the desktop, and left me again at the login screen. After fumbling around a bit I found that “CTRL+ALT+F4” launched okay from that login screen and I was able to complete the upgrade for the remaining Plasma items successfully. Just noting in case others encounter this situation.

If you are still in that situation, you are better off trying

zypper --no-refresh dup

and install packages still in the cache, if there are some, to complete the upgrade to TW snapshot 20240311.
Then you can use the regular “zypper dup” to get the two other snapshots that have been published meanwhile.

Thank you, Bruno! Yes, I am still in that situation, and I will do right now what you recommended.

Dear Bruno, dear Basilcat,

So I did now what you recommended:

  1. I changed to a terminal via CTLR+ALT+F4.

  2. I ran zypper --no-refresh dup

  3. I rebooted afterwards.

  4. I run a software update from YAST then, which did nothing as far as I can tell.

  5. I then changed to a terminal again and ran “zypper dup”, which did a lot.

  6. However, at least my key problem persists, namely that my latex editor “kile” does not start, but rather complains that it cannot find a current version of the “okular” library. Any comments on that?

Why number 4? That is not what was recommended.

That is true indeed, but the system was rebooting into graphical mode, and I hoped that I was fine at that point. In any case, I do not think that anything happened at that point.

As you should NEVER do that in Tumbleweed, you are lucky.

I did not know that! Why not?

I updated 1 Tumbleweed laptop to Plasma 6… I won’t be updating my other 3 for awhile. :thinking:

If only I had seen this post before I updated my system! Now it’s broken.

1 Like

:rofl: :joy: :rofl: :joy:
Yes, I’m not impressed with Plasma 6 right now.
That’s why I making this post on my Leap 15.6 Beta laptop. Even this beta is in better shape than my Tumbleweed with KDE 6.
IMHO I think it’s nice to have both Tumbleweed and Leap available.