Headphones and speakers playing at the same time

Hello, I’m having trouble to get the headphones working when the speakers are already connected.

When I set the option Connector as Line Out on KDE Settings->Multimedia->Audio and Video Settings->Audio Hardware Setup the speakers work fine but when I plug in the headphones I’ve got no sound from them, If I unplug the speakers (back) and then plug the headphones (front) the headphones work.
Otherwise if I set the option Connector as Headphones on KDE **Settings->Multimedia->Audio and Video Settings->Audio Hardware Setup **the speakers and headphones play simultaneously.

Is there a way to make my system detect when I plug in a new audio device and switch to it?

I’m running openSUSE 13.2 and I have the following sound Hardware (the 0 card is the one it counts):


cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xfbff4000 irq 44
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfbefc000 irq 45


I’ve tried editing /etc/modprobe.d/50-sound.conf like this:


options snd-hda-intel model=z71v position_fix=1
#options snd slots=snd-hda-intel,snd-hda-intel
# u1Nb.W7NMTVFx8WB:6 Series/C200 Series Chipset Family High Definition Audio Controller
alias snd-card-0 snd-hda-intel
# NXNs.Pm4Ny6xAJv4:Turks/Whistler HDMI Audio [Radeon HD 6000 Series]
alias snd-card-1 snd-hda-intel

with no results (after restarting the sound server).

I suggest you install pavulcontrol and use that to see if you can control the source/sinks

If the excellent suggestion of gogalthorp to try pavucontrol does not work, you may be into bug reporting territory.

You could (to give more information) as a regular user remove that 50-sound.conf custom config, reboot,in and then in a konsole/xterm run the diagnostic script with PC connected to internet :

 
/usr/sbin/alsa-info.sh

and do not update if asked to update, and select the SHARE/UPLOAD option, and let script run to completion. When script has completed in the konsole/xterm should be the web address/URL where it has uploaded a detailed listing of the audio configuration of your PC. Copy the webaddress/URL (just the address) to this forum and we can look at it.

wrt pavucontrol, you can find more on how to use it in these two blogs:

I note your PC has two intel sound module instances running at once - card-one for HDMI and card-zero for analog/digital sound. This can sometimes cause a user problems if the PC instead boots with the HDMI devices as card-0 (although for your PC I see the HDMI device is card-1 and the analog/digital sound is card-0).

But as noted, this could be bug reporting territory.

Thanks for the feedback, I tried using pavucontrol or “PulseAudio Volume Control” without success.
With the microphone it only says “plugged in” on the rear plug not with the front one, although both work (I don’t have two mics right know to test if this “overlapping” happen with the mics too).
With the speakers it only says “plugged in” on the rear plug too.

I’ve reverted to the default config and ran the script, this is the output:
http://www.alsa-project.org/db/?f=9d595a5ab20dc5fc08898bcc75c1b8e1e1d2d164

I noted this in the script:


Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 0 [0%] -62.00dB] [off]
  Front Right: Playback 0 [0%] -62.00dB] [off]

If you switch that ON and move the volume levels UP from the 0% mute, does that help the behaviour ?